1002 A+B for Polynomials (25 分)
时间限制: 400 ms 内存限制: 64 MB 代码长度限制: 16 KB
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
AC算法一:
#include<iostream>
#include<cstring>
using namespace std;
#define MAX 1001
double a[MAX];
void nInit();
void nInput(int k);
void nAdd(int k);
void nOutput();
int main()
{
int nA,nB;
while(cin>>nA)
{
nInit();
nInput(nA);
cin>>nB;
nInput(nB);
nOutput();
}
return 0;
}
void nInit()
{
memset(a,0,sizeof(a));
}
void nInput(int k)
{
int i,n;
double temp;
for(i=1;i<=k;i++)
{
cin>>n;
cin>>temp;
a[n]+=temp;
}
}
void nOutput()
{
int i;
int count;
count=0;
for(i=1000;i>=0;i--)
{
if(a[i]==0)
{
continue;
}
else
{
count++;
}
}
cout<<count;
for(i=1000;i>=0;i--)
{
if(a[i]==0)
{
continue;
}
else
{
printf(" %d %.1lf",i,a[i]);
}
}
cout<<endl;
}
AC算法二:
#include<bits/stdc++.h>
using namespace std;
#define MAX 1001
double Na[MAX],Nb[MAX],N[MAX];
int num;
int ka,kb;
void vInit();
void vInput();
void vAdd();
void vOutput();
int main()
{
while(cin>>ka)
{
vInit();
vInput();
vAdd();
vOutput();
}
return 0;
}
void vInit()
{
memset(Na,0,sizeof(Na));
memset(Nb,0,sizeof(Nb));
memset(N,0,sizeof(N));
num=0;
}
void vInput()
{
int na,nb;
double ana,anb;
for(int i=1;i<=ka;i++)
{
cin>>na>>ana;
Na[na]=ana;
}
cin>>kb;
for(int i=1;i<=kb;i++)
{
cin>>nb>>anb;
Nb[nb]=anb;
}
}
void vAdd()
{
for(int i=0;i<MAX;i++)
{
N[i]=Na[i]+Nb[i];
}
for(int i=0;i<MAX;i++)
{
if(N[i]!=0)
{
num++;
}
}
}
void vOutput()
{
cout<<num;
for(int i=MAX-1;i>=0;i--)
{
if(N[i]!=0)
{
printf(" %d %.1lf",i,N[i]);
}
}
cout<<endl;
}