Have Fun with Numbers

7-7 Have Fun with Numbers (20 分)

                                                                                                      时间限制: 400 ms      内存限制: 64 MB    代码长度限制: 16 KB

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

 

AC算法

#include<stdio.h>  
int ans[10];  
char num1[22];  
char num2[22];  
int main(void){  
 while (scanf("%s", num1) != EOF){  
  for (int k = 0; k< 10; k++){  
   ans[k] = 0;  
  }  
  int di = 0, jin = 0,ji = 0;  
  int i;  
  for (i = 21; num1[i] == 0; i--);
  for ( ; i >= 0; i -- ){  
   ji = (num1[i] - '0') * 2;  
   ans[num1[i] - '0'] ++;
   di = ji % 10;
   num2[i] = di + jin + '0';  
   ans[num2[i] - '0'] --;
   jin = (ji + jin) / 10;  
  }  
  if (jin != 0)ans[jin] ++;  
  for (i = 1; i < 10; i++){  
   if (ans[i] != 0)break;  
  }
  if (i == 10){  
   puts("Yes");  
  }  
  else {  
   puts("No");  
  }  
  if (jin != 0)printf("%d", jin);  
  puts(num2);  
 }  
 return 0;  
}  

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值