人见人爱A^B
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33473 Accepted Submission(s): 22696
Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
Sample Input
2 3
12 6
6789 10000
0 0
Sample Output
8
984
1
Author
lcy
Source
ACM程序设计期末考试(2006/06/07)
来源: http://acm.hdu.edu.cn/showproblem.php?pid=2035
#include <cstdio>
#define max 1000000
char A[max+1]={7,11};
int Cal (int A,int B)
{
int ans=1;
while(B)
{
if(B&1) ans=((ans%1000)*(A%1000))%1000;
A=(A%1000)*(A%1000);
B>>=1;
}
return ans;
}
int main()
{
int A,B;
while(~scanf("%d %d",&A,&B)&&A&&B)
printf("%d\n",Cal(A,B));
return 0;
}