hdu2639 Bone Collector II (01背包第k大解)

Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0
 

Author
teddy
 

Source
 


题意:给出一行价值,一行体积,让你在v体积的范围内找出第k大的值;

思路:01背包的进一步优化,普通的背包是求得最大值;

          需要求第k大,我们需要在dp数组上多开一维,记录v体积下第k大的值;

          然后我们利用01背包思想将原值与新得到的值进行按大小合并;

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=105;
int dp[1010][50];
int value[maxn],weight[maxn];
int a[50],b[50];
int n,V,K;
void solve_dp()
{
    memset(dp,0,sizeof(dp));
    for(int i=0;i<n;i++)
        for(int j=V;j>=weight[i];j--)
        {
            for(int k=1;k<=K;k++)
            {
                a[k]=dp[j][k];
                b[k]=dp[j-weight[i]][k]+value[i];
            }
            int x,y,z;
            x=y=z=1;
            a[K+1]=b[K+1]=-1;
            while((z<=K)&&(x<=K||y<=K))  //合并
            {
                if(a[x]>b[y]) dp[j][z]=a[x++];
                else dp[j][z]=b[y++];
                if(dp[j][z]!=dp[j][z-1]) z++;
            }
        }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&V,&K);
        for(int i=0;i<n;i++)
            scanf("%d",&value[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&weight[i]);
        solve_dp();
        printf("%d\n",dp[V][K]);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值