<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[helencoder的博客]]></title><description><![CDATA[PHP、足球、逗比]]></description><link>https://blog.youkuaiyun.com/helencoder</link><language>zh-cn</language><generator>https://blog.youkuaiyun.com/</generator><copyright><![CDATA[Copyright &copy; helencoder]]></copyright><item><title><![CDATA[ab性能测试]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/52457078</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/52457078</guid><author>helencoder</author><pubDate>Wed, 07 Sep 2016 10:21:30 +0800</pubDate><description><![CDATA[首先分享两篇不错的文章：（总结）Web性能压力测试工具之ApacheBench（ab）详解 
widows系统下ab使用指南：如何使用Apache的ab工具进行网站性能测试实际测试命令： 
利用cmd(管理员模式)进入apache安装目录的bin目录下执行相应的ab命令：ab常用参数的介绍： 
-n ：总共的请求执行数，缺省是1； 
-c： 并发数，缺省是1； 
-t：测试所进行的总时间，秒为单位，]]></description><category></category></item><item><title><![CDATA[基于原生PHP的路由分配实现]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/52065969</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/52065969</guid><author>helencoder</author><pubDate>Fri, 29 Jul 2016 16:07:03 +0800</pubDate><description><![CDATA[对于由原生PHP写成的独立PHP框架，利用单一入口文件实现路径的访问。这时我们会遇到的首要问题是：文件的相互包含，其次就是路由分配。当我们不利用成熟的PHP框架进行web开发时，我们就会发现上述两个问题会是很困扰我们的问题所在。
问题解决方案：
    1、文件包含
    php的文件包含有两种方式：require和include，两个方法的区别在于利用require包含文件当出错时，会报出严重错]]></description><category></category></item><item><title><![CDATA[StarUML软件设计建模工具破解]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51932722</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51932722</guid><author>helencoder</author><pubDate>Sun, 17 Jul 2016 15:58:16 +0800</pubDate><description><![CDATA[参考：http://bbs.chinapyg.com/thread-79022-1-1.html 
各平台版本均适用，本文更改的为Mac版本。​1，打开对应 mac版本的安装包位置，在对应目录/Applications/StarUML.app/Contents/www/license/node/LicenseManagerDomain.js文件。 
2，找到文件23行，修改对应下面函数。更改为如下代]]></description><category></category></item><item><title><![CDATA[Node.js操作redis示例及常用命令汇总]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51784654</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51784654</guid><author>helencoder</author><pubDate>Wed, 29 Jun 2016 17:30:34 +0800</pubDate><description><![CDATA[利用redis、co-redis进行redis操作
redis操作示例]]></description><category></category></item><item><title><![CDATA[npm清除未被使用的模块命令]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51576442</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51576442</guid><author>helencoder</author><pubDate>Fri, 03 Jun 2016 09:28:39 +0800</pubDate><description><![CDATA[我们使用npm list 的过程中，可能会出现这样的一些问题，就是有些模块未被项目引入，但是我们还是安装了这些模块，这时就会出现报错的情况。 
这时我们只需要简单的一行命令即可解决！npm prune]]></description><category></category></item><item><title><![CDATA[远程数据库拉取相关问题]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51576420</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51576420</guid><author>helencoder</author><pubDate>Fri, 03 Jun 2016 09:26:11 +0800</pubDate><description><![CDATA[在实际的业务开发过程中，我们可能遇到需要将线上数据库的数据拉取到本地进行本地测试开发，这时我们需要进行数据库的远程拉取。
本文章主要介绍远程数据库拉取相关问题！]]></description><category></category></item><item><title><![CDATA[中奖概率算法]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51404410</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51404410</guid><author>helencoder</author><pubDate>Sat, 14 May 2016 10:01:31 +0800</pubDate><description><![CDATA[function getRand($proArr) { //传入的为一维数字数组,此数组中数字即为相应概率
        $result = '';
        //概率数组的总概率精度
        $proSum = array_sum($proArr);
        //概率数组循环
        foreach ($proArr as $key => $proCur) {]]></description><category></category></item><item><title><![CDATA[PHP推荐标准(PSR)]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51333598</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51333598</guid><author>helencoder</author><pubDate>Fri, 06 May 2016 18:04:25 +0800</pubDate><description><![CDATA[PSR是PHP Standards Recommendation的简称。PSR-1： 基本的代码风格 
PHP标签 
    必须把PHP代码放在<?php ?> 或 <?= ?> 标签中。不得使用其他PHP标签语法。 
编码 
    所有PHP文件都必须使用UTF-8字符集编码，而且不能有字节顺序标记 
目的 
    一个PHP文件可以定义符号（类、性状、函数和常量等），或者执行有副作用的操作]]></description><category></category></item><item><title><![CDATA[redis在PHP中的基本使用案例]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51275759</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51275759</guid><author>helencoder</author><pubDate>Thu, 28 Apr 2016 16:51:28 +0800</pubDate><description><![CDATA[利用phpredis实现php操作redis，需要进行redis.so的下载，添加//利用Redis类进行操作//实例化Redis类
$redis = new Redis();
//选择指定的redis数据库连接，默认端口号为6379
$redis->connect('127.0.0.1', 6379);//普通set/get操作
$redis->set(‘library’, ‘predis’);]]></description><category></category></item><item><title><![CDATA[Linux 文件系统的目录结构]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51254008</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51254008</guid><author>helencoder</author><pubDate>Tue, 26 Apr 2016 20:56:38 +0800</pubDate><description><![CDATA[Linux 文件系统的目录结构 
转自： Linux 文件系统的目录结构  Linux下的文件系统为树形结构，入口为/ 树形结构下的文件目录： 无论哪个版本的Linux系统，都有这些目录，这些目录应该是标准的。各个Linux发行版本会存在一些小小的差异，但总体来说，还是大体差不多。
/ 文件系统的入口，最高一级目录；
/bin 基础系统所需要的命令位于此目录，是最小系统所需要的命令，如：ls, cp]]></description><category></category></item><item><title><![CDATA[HTTP状态码]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51225747</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51225747</guid><author>helencoder</author><pubDate>Sat, 23 Apr 2016 12:42:26 +0800</pubDate><description><![CDATA[HTTP状态码（HTTP Status Code）是用以表示网页服务器HTTP响应状态的3位数字代码。它由 RFC 2616 规范定义的，并得到RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。 
消息（1字头） 
这一类型的状态码，代表请求已被接受，需要继续处理。这类响应是临时响应，只包含状态行和某些可选的响应头信息，并以空行结束。由于 HTTP/]]></description><category></category></item><item><title><![CDATA[邮件发送（PHP实现）]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51195221</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51195221</guid><author>helencoder</author><pubDate>Tue, 19 Apr 2016 23:36:50 +0800</pubDate><description><![CDATA[用过PHP的人基本都知道，PHP有一个函数mail(),专门用来发送邮件，但是当你实际用过你才发现，是有多么的费劲，你需要自己去实现SMTP服务，当前假如你想也不是不可能。 
但是假如存在这么一种简便方法呢。借助已有的smtp.php类就可以轻松的实现邮件发送。何乐而不为呢！ 
代码示例如下： 
首先引入：下载smtp.php文件，下载链接：smtp.php使用代码如下： 
为了使用更简洁，我们可以]]></description><category></category></item><item><title><![CDATA[MySQL数据库操作类(PHP实现，支持连贯操作)]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51172389</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51172389</guid><author>helencoder</author><pubDate>Sun, 17 Apr 2016 11:27:47 +0800</pubDate><description><![CDATA[使用过ThinkPHP框架的同学可能会对于其中数据库模型操作特别有好感，ThinkPHP提供了数据库操作的简单的操作，对于连接数据库，数据库的增删改查等数据操作都非常的nice，同时支持连贯操作，对于那些不习惯写sql语句的同学真是大大的便利。(注：sql还是很重要的，不要因为用了框架就把原先的忘了)。 
而在笔者使用php操作redis实现后台任务的过程中，也想要借助这种便利，但无奈redis操作]]></description><category></category></item><item><title><![CDATA[经典排序算法的PHP实现类]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51169537</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51169537</guid><author>helencoder</author><pubDate>Sat, 16 Apr 2016 19:01:05 +0800</pubDate><description><![CDATA[近期广受笔试摧残，对于各种排序也是晕头转向。 
更坑爹的是貌似大多都是用C++、Java实现相关算法，让我搞PHP的情何以堪，更何况，PHP本身就有排序函数sort()，其实来说，是很简单的，这也可能是为什么不用PHP进行排序吧。 
但考虑到PHP毕竟也是一门面向对象的语言吧，我们利用原生的语法，也是可以实现经典排序算法的，先不说性能如何，切不要妄自菲薄吧。 
下面为具体的经典排序算法的PHP实现类]]></description><category></category></item><item><title><![CDATA[Github上的PHP资源汇总]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51161496</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51161496</guid><author>helencoder</author><pubDate>Fri, 15 Apr 2016 14:35:43 +0800</pubDate><description><![CDATA[目录[-]


依赖管理
依赖管理的附加部分
框架
框架的附加部分
框架组件
微型框架
微型框架的附加部分
模板
静态站点生成器
HTTP
URL
Email
文件
流
依赖注入
图像
测试
持续集成
文档
安全性
密码
代码分析
调试
构建工具
任务运行器
导航
资源管理
地理定位
日期和时间
事件
日志
电子商务
PDF]]></description><category></category></item><item><title><![CDATA[Git 设置不需要用户名、密码直接push的操作]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51156287</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51156287</guid><author>helencoder</author><pubDate>Fri, 15 Apr 2016 00:04:23 +0800</pubDate><description><![CDATA[GitHub作为一个专业的平台，为我们便捷、安全的操作代码提供了很好的平台。 
但是我们可能遇到在使用过程中，push时需要输入用户名、密码。这很烦。]]></description><category></category></item><item><title><![CDATA[Ajax的XMLHttpRequest对象的属性和方法]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51153523</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51153523</guid><author>helencoder</author><pubDate>Thu, 14 Apr 2016 17:36:09 +0800</pubDate><description><![CDATA[XMLHttpRequest对象是Ajax的核心，它有很多的属性、方法和事件以便于脚本处理和控制HTTP的请求和相应。 
一、XMLHttpRequest对象的属性和事件属性 描述readyState      表示XMLHttpRequest对象的状态responseText    包含客户端接收到的HTTP相应的文本内容responseXML     服务器响应的XML内容对应的DOM对象sta]]></description><category></category></item><item><title><![CDATA[jQuery Ajax()常用方法和参数的使用样例]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51152526</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51152526</guid><author>helencoder</author><pubDate>Thu, 14 Apr 2016 16:23:20 +0800</pubDate><description><![CDATA[jQuery Ajax()方法本身具有多个参数可供选择。$.ajax({
    type:"POST",                    //String 默认为GET
    timeout:2000,                   //Number 设置超时时间（毫秒）
    url:"{:U('testOAuthAPI')}",     //String 发送请求的地址]]></description><category></category></item><item><title><![CDATA[利用redis和php-resque实现后台任务]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51122424</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51122424</guid><author>helencoder</author><pubDate>Mon, 11 Apr 2016 15:56:23 +0800</pubDate><description><![CDATA[在PHP的页面编程过程中，我们总遇到这样一个问题，即是PHP是一个顺序执行的过程，只能在一个任务完成后接着去实现下一个任务，而这其中存在一个问题，就是假如其中一个任务耗费大量时间的时候，我们可能就必须要等待。借助redis可以将耗时任务放到后台去执行，从而减少等待时间。]]></description><category></category></item><item><title><![CDATA[微信JSSDK页面授权实现类(PHP)]]></title><link>https://blog.youkuaiyun.com/helencoder/article/details/51121718</link><guid>https://blog.youkuaiyun.com/helencoder/article/details/51121718</guid><author>helencoder</author><pubDate>Mon, 11 Apr 2016 14:54:15 +0800</pubDate><description><![CDATA[微信页面授权–(JS-SDK使用权限签名算法) 
使用方法：实例化此类，然后调用其中的getSignPackage()方法即可。 
注意：其中涉及获取access_token和jsapi_ticket需要自己缓存，不能频繁获取！
<?php
/**
 * Author: helen
 * CreateTime: 2016/4/11 10:39
 * description: 微信页面授权--(JS-]]></description><category></category></item></channel></rss>