POJ 1002 487-3279(字符串处理)排序

博客围绕企业电话号码记忆方式及标准格式展开,介绍了字母与数字的映射规则。企业编写电话号码薄时,需检查是否有重复号码。输入指定号码数量及号码,输出重复号码的标准格式和重复次数,还给出相关函数参考链接。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 271726 Accepted: 48379
Description:

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino’s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their “three tens” number 3-10-10-10.
The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:
A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9
There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.
Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)
Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input:

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output:

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:
No duplicates.

Sample Input:

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279
Sample Output:

310-1010 2
487-3279 4
888-4567 3

中文翻译:
Description:

企业喜欢用容易被记住的电话号码。让电话号码容易被记住的一个办法是将它写成一个容易记住的单词或者短语。例如,你需要给滑铁卢大学打电话时,可以拨打TUT-GLOP。有时,只将电话号码中部分数字拼写成单词。当你晚上回到酒店,可以通过拨打310-GINO来向Gino’s订一份pizza。让电话号码容易被记住的另一个办法是以一种好记的方式对号码的数字进行分组。通过拨打必胜客的“三个十”号码3-10-10-10,你可以从他们那里订pizza。
电话号码的标准格式是七位十进制数,并在第三、第四位数字之间有一个连接符。电话拨号盘提供了从字母到数字的映射,映射关系如下:
A, B, 和C 映射到 2
D, E, 和F 映射到 3
G, H, 和I 映射到 4
J, K, 和L 映射到 5
M, N, 和O 映射到 6
P, R, 和S 映射到 7
T, U, 和V 映射到 8
W, X, 和Y 映射到 9
Q和Z没有映射到任何数字,连字符不需要拨号,可以任意添加和删除。 TUT-GLOP的标准格式是888-4567,310-GINO的标准格式是310-4466,3-10-10-10的标准格式是310-1010。
如果两个号码有相同的标准格式,那么他们就是等同的(相同的拨号)
你的公司正在为本地的公司编写一个电话号码薄。作为质量控制的一部分,你想要检查是否有两个和多个公司拥有相同的电话号码。
Input:

输入的格式是,第一行是一个正整数,指定电话号码薄中号码的数量(最多100000)。余下的每行是一个电话号码。每个电话号码由数字,大写字母(除了Q和Z)以及连接符组成。每个电话号码中只会刚好有7个数字或者字母。

Output:

对于每个出现重复的号码产生一行输出,输出是号码的标准格式紧跟一个空格然后是它的重复次数。如果存在多个重复的号码,则按照号码的字典升序输出。如果输入数据中没有重复的号码,输出一行:

注:

qsort()函数的功能是对数组进行排序:https://www.cnblogs.com/laizhenghong2012/p/8442270.html
strcmp()字符串比较函数:https://blog.youkuaiyun.com/weixin_40093087/article/details/78071718

代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char map[26] = {'2', '2', '2', '3', '3', '3', '4', '4', '4',
                '5', '5', '5', '6', '6', '6', '7', '7', '7',
                '7', '8', '8', '8', '9', '9', '9', '9'};//按键映射表
char phone[100000][9];//全部电话号码
int n;         //电话号码的数量
char number[80];//一个未经处理的电话号码
int main(void)
{
    int loop;//循环变量
    int phone_i=0, phone_j=0;//phone数组的下标
    int tag = 0;//重复标志,0没有处于一个重复,1有重复
    int count = 1;//重复次数
    scanf("%d", &n);
    for(phone_i=0; phone_i<n; phone_i++){//格式化所有输入数据为111-1111的形式
        scanf("%s", &number);
        for(loop=0; number[loop]!='\0'; loop++){//检查每一个字符
            if(phone_j == 3){//第四个字符必须是'-'
                phone[phone_i][phone_j] = '-';
                phone_j++;
            }
            if(number[loop]>='0' && number[loop]<='9'){//当前字符是数字
                phone[phone_i][phone_j] = number[loop];
            }
            else if(number[loop]>='A' && number[loop]<='Z'){//当前字符是大写字母
                phone[phone_i][phone_j] = map[number[loop]-'A'];//将字母转换为ASCII码值
            }
            else if(number[loop] == '-'){//忽略'-'
                continue;
            }
            phone_j++;
        }
        phone_j = 0;
    }
    //排序全部电话号码
    qsort(phone, n, 9, strcmp);//快速排序
    for(loop=1; loop<n; loop++){//检查重复次数,输出结果
        if(strcmp(phone[loop], phone[loop-1]) == 0){
            tag = 1;
            count++;
        }
        else{//没有重复
            if(count > 1){
                printf("%s %d\n", phone[loop-1], count);
            }
            count = 1;
        }
    }
    if(count > 1){//查看最后一条记录是否有重复
        printf("%s %d\n", phone[loop-1], count);
    }
    if(!tag)
        printf("No duplicates.\n");
    return 0;
}
解决ESP32烧录MicroPython时esptool.py未识别的错误 当出现esptool.py not recognized错误时,通常是由于环境变量未正确配置或工具未安装。以下是逐步解决方法: 1. 确认esptool.py是否安装 安装命令: Bash pip install esptool # 或使用Python3 pip3 install esptool 如果已安装但版本过旧,可升级: Bash pip install --upgrade esptool 2. 检查环境变量配置 Windows系统: Python脚本默认安装路径为C:\Users\<用户名>\AppData\Local\Programs\Python\PythonXX\Scripts(XX为版本号)。 将此路径添加到系统环境变量PATH中4。 修改后需重启命令行工具或IDE(如VS Code)。 Linux/macOS系统: Bash export PATH="$PATH:$HOME/.local/bin" 可将此命令添加到~/.bashrc或~/.zshrc中永久生效。 3. 通过Python模块直接运行 若环境变量未生效,可显式调用Python模块: Bash python -m esptool --help # 或指定Python3 python3 -m esptool --help 4. 检查开发环境配置 如果使用ESP-IDF框架,确保已执行环境初始化脚本: Bash # Linux/macOS . $IDF_PATH/export.sh # Windows %IDF_PATH%\export.bat 此步骤可能影响工具链路径的识别。 5. 验证命令格式 确保烧录命令正确,典型MicroPython烧录命令示例: Bash esptool.py --port COM3 erase_flash esptool.py --port COM3 --baud 460800 write_flash -z 0x1000 firmware.bin 替换COM3为实际串口号,firmware.bin为固件路径。 6. 重装或修复工具 若问题持续,尝试: 卸载后重装: Bash pip uninstall esptool pip install esptool 检查系统架构兼容性(如32/64位系统或文件损坏问题,参考文件格式错误解决方法35)。第二步的具体步骤
03-14
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值