Sinking Ship
时间限制:
2000 ms | 内存限制:
65535 KB
难度:
1
-
描述
-
The ship crashed into a reef and is sinking. Now the entire crew must be evacuated. All n crew members have already lined up in a row (for convenience let's label them all from left to right with positive integers from 1 to n) and await further instructions. However, one should evacuate the crew properly, in a strict order. Specifically:The first crew members to leave the ship are rats. Then women and children (both groups have the same priority) leave the ship. After that all men are evacuated from the ship. The captain leaves the sinking ship last.If we cannot determine exactly who should leave the ship first for any two members of the crew by the rules from the previous paragraph, then the one who stands to the left in the line leaves the ship first (or in other words, the one whose number in the line is less).For each crew member we know his status as a crew member, and also his name. All crew members have different names. Determine the order in which to evacuate the crew.
-
输入
- The first line contains an integer n, which is the number of people in the crew (1 ≤ n ≤ 100). Then follow n lines. The i-th of those lines contains two words — the name of the crew member who is i-th in line, and his status on the ship. The words are separated by exactly one space. There are no other spaces in the line. The names consist of Latin letters, the first letter is uppercase, the rest are lowercase. The length of any name is from 1 to 10 characters. The status can have the following values: rat for a rat, woman for a woman, childfor a child, man for a man, captain for the captain. The crew contains exactly one captain. 输出
- Print n lines. The i-th of them should contain the name of the crew member who must be the i-th one to leave the ship. 样例输入
-
6 Jack captain Alice woman Charlie man Teddy rat Bob child Julia woman
样例输出
-
Teddy Alice Bob Julia Charlie Jack
思路~ 遍历n然后srtrcmp匹配 符合条件标记下 下次便利忽略
#include <iostream>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
#include <queue>
#include <stack>
using namespace std;
struct chuasn{
char a[15];
char b[15];
int flag;
}Q[110];
int main()
{
int n;
while(~scanf("%d",&n)){
for(int i=1;i<=n;i++){
cin>>Q[i].a;
cin>>Q[i].b;
Q[i].flag=1;
}
for(int i=1;i<=n;i++){
if(!strcmp(Q[i].b,"rat")&&Q[i].flag){
cout<<Q[i].a<<endl;
Q[i].flag=0;
}
}
for(int i=1;i<=n;i++){
if((!strcmp(Q[i].b,"woman")&&Q[i].flag)||(!strcmp(Q[i].b,"child")&&Q[i].flag)){
cout<<Q[i].a<<endl;
Q[i].flag=0;
}
}
for(int i=1;i<=n;i++){
if(!strcmp(Q[i].b,"man")&&Q[i].flag){
cout<<Q[i].a<<endl;
Q[i].flag=0;
}
}
for(int i=1;i<=n;i++){
if(Q[i].flag!=0){
cout<<Q[i].a<<endl;
Q[i].flag=0;
}
}
}
return 0;
}