PKU-3264 Balanced Lineup (RMQ之线段树)

原题链接 http://poj.org/problem?id=3264

Balanced Lineup

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source Code

/*
RMQ (Range Minimum/Maximum Query)问题-------线段树的应用
*/

#include <iostream>
using namespace std;

struct node {
	int low, high;
	int Max, Min;
	node *leftchild, *rightchild;
};

//先分配内存,然后重复利用
node num[200001];
int index;                  

//new新结点
node * NewNode() {
	node *p = &num[index ++];
	return p;
}

//构建线段树
node * createSegTree(int low, int high, int *heights) {
	
	node * root = NewNode();
	root->low = low;
	root->high = high;

	//叶子结点
	if (low == high) {
		root->Max = heights[low];
		root->Min = heights[high];
        root->leftchild = NULL;
		root->rightchild = NULL;
	} else {
		int mid = (low + high) / 2;
		
		//左子树low~mid, 右子树mid+1~high
		root->leftchild = createSegTree(low, mid, heights);
		root->rightchild = createSegTree(mid + 1, high, heights);
		
		//更新最大值
		if (root->leftchild->Max > root->rightchild->Max) {
			root->Max = root->leftchild->Max;
		} else {
			root->Max = root->rightchild->Max;
		}

		//更新最小值
		if (root->leftchild->Min < root->rightchild->Min) {
			root->Min = root->leftchild->Min;
		} else {
			root->Min = root->rightchild->Min;
		}
	}

	return root;
}

//查询最大值
int getMax(node * root, int low, int high) {
	
	if (root->low == low && root->high == high) {
		return root->Max;
	} else {
		int mid = (root->low + root->high) / 2;
		if (mid >= high) {
			return getMax(root->leftchild, low, high);
		} else if (mid < low) {
			return getMax(root->rightchild, low, high);
		} else {
			int leftMax = getMax(root->leftchild, low, mid);
			int rightMax = getMax(root->rightchild, mid + 1, high);
			if (leftMax > rightMax) {
				return leftMax;
			} else {
				return rightMax;
			}
		}
	}
}

//查询最小值
int getMin(node *root, int low, int high) {
	
	if (root->low == low && root->high == high) {
		return root->Min;
	} else {
		int mid = (root->low + root->high) / 2;
		if (mid >= high) {
			return getMin(root->leftchild, low, high);
		} else if (mid < low) {
			return getMin(root->rightchild, low, high);
		} else {
			int leftMin = getMin(root->leftchild, low, mid);
			int rightMin = getMin(root->rightchild, mid + 1, high);
			if (leftMin < rightMin) {
				return leftMin;
			} else {
				return rightMin;
			}
		}
	}
}

int main() {
	int N, Q, heights[50005];
	int i, start, end;
	while(scanf("%d %d", &N, &Q) != EOF) {
		for (i = 1; i <= N; i++) {
			scanf("%d", &heights[i]);
		}

		index = 0;
		node * head = createSegTree(1, N, heights);

		while(Q --) {
			scanf("%d %d", &start, &end);
			if (start == end) {
				printf("0\n");
			} else {
				printf("%d\n", getMax(head, start, end) - getMin(head, start, end));
			}	
		}
	}
}
内容概要:该论文研究了一种基于行波理论的输电线路故障诊断方法。当输电线路发生故障时,故障点会产生向两侧传播的电流和电压行波。通过相模变换对三相电流行波解耦,利用解耦后独立模量间的关系确定故障类型和相别,再采用小波变换模极大值法标定行波波头,从而计算故障点距离。仿真结果表明,该方法能准确识别故障类型和相别,并对故障点定位具有高精度。研究使用MATLAB进行仿真验证,为输电线路故障诊断提供了有效解决方案。文中详细介绍了三相电流信号生成、相模变换(Clarke变换)、小波变换波头检测、故障诊断主流程以及结果可视化等步骤,并通过多个实例验证了方法的有效性和准确性。 适合人群:具备一定电力系统基础知识和编程能力的专业人士,特别是从事电力系统保护与控制领域的工程师和技术人员。 使用场景及目标:①适用于电力系统的故障检测与诊断;②能够快速准确地识别输电线路的故障类型、相别及故障点位置;③为电力系统的安全稳定运行提供技术支持,减少停电时间和损失。 其他说明:该方法不仅在理论上进行了深入探讨,还提供了完整的Python代码实现,便于读者理解和实践。此外,文中还讨论了行波理论的核心公式、三相线路行波解耦、行波测距实现等关键技术点,并针对工程应用给出了注意事项,如波速校准、采样率要求、噪声处理等。这使得该方法不仅具有学术价值,也具有很强的实际应用前景。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值