PKU-1001 Exponentiation(浮点数相乘)

原题链接 http://poj.org/problem?id=1001

Exponentiation

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
Source Code
/*
高精度乘法:

算法思想:

  1、小数先转化成整数,并去掉小数末尾的0
  2、整数模拟相乘(利用整型数组存储结果),每一位乘以乘数,结果%10存在当前位,结果/10作为进位
  3、考虑多种情况倒序输出结果

*/

#include <iostream>
using namespace std; 

int result[1000];

/*字符串转化为整数*/
int strToInt(char *ch, int &digit) {
    
	int i;
	int num = 0;
	bool afterPoint = false;
	
	for (i = 0; ch[i] != '\0'; i++) {
		if (ch[i] == '.') {
			afterPoint = true;
		} else {
			num = num * 10;
			num += (ch[i] - '0');
			if (afterPoint) {
				digit ++;
			}
		}		
	}

	/*如果小数末尾存在0,去除*/
	int len = i;
	if (afterPoint) {
		for (i = len - 1; i >=0 ; i--) {
			if (ch[i] == '0') {
				num = num / 10;
				digit --;
			} else {
				break;
			}
		}
	}
	
	return num;
}

int main() {

	char num_ch[10];
	int i, j;
	int exponent, digit, num, len;

	while(scanf("%s %d", num_ch, &exponent)!=EOF) {

		digit = 0;
		len = 0;
        num = strToInt(num_ch, digit);
 
		int temp = num;
		while (temp != 0) {
			result[len ++] = temp % 10;
			temp /= 10; 
		}
 
		//模拟相乘exponent-1次
		int ret = 0;
		for (i = 0; i < exponent - 1; i ++) {
			ret = 0;
			for (j = 0; j < len; j ++) {
				 temp = result[j] * num + ret;
			     result [j] = temp % 10;
				 ret = temp / 10;
			}
            while (ret != 0) {
				result[len ++] = ret % 10;
				ret /= 10;
			}
		}

		//输出结果
		if (!digit) {
			for (i = len - 1; i >= 0; i--) {
				printf("%d",result[i]);
			}
		} else if (len <= digit * exponent) {
			printf(".");
			for (i = digit * exponent - len; i > 0; i--){
				printf("0");
			}
			for (i = len - 1; i >= 0; i--) {
				printf("%d", result[i]);
			}
		} else {
			for (i = len - 1; i > digit * exponent - 1; i--) {
				printf("%d", result[i]);
			}
			printf(".");
			for (; i >= 0; i--) {
				printf("%d", result[i]);
			}
		}
		printf("\n");
	}

}


 

内容概要:该论文研究了一种基于行波理论的输电线路故障诊断方法。当输电线路发生故障时,故障点会产生向两侧传播的电流和电压行波。通过相模变换对三相电流行波解耦,利用解耦后独立模量间的关系确定故障类型和相别,再采用小波变换模极大值法标定行波波头,从而计算故障点距离。仿真结果表明,该方法能准确识别故障类型和相别,并对故障点定位具有高精度。研究使用MATLAB进行仿真验证,为输电线路故障诊断提供了有效解决方案。文中详细介绍了三相电流信号生成、相模变换(Clarke变换)、小波变换波头检测、故障诊断主流程以及结果可视化等步骤,并通过多个实例验证了方法的有效性和准确性。 适合人群:具备一定电力系统基础知识和编程能力的专业人士,特别是从事电力系统保护与控制领域的工程师和技术人员。 使用场景及目标:①适用于电力系统的故障检测与诊断;②能够快速准确地识别输电线路的故障类型、相别及故障点位置;③为电力系统的安全稳定运行提供技术支持,减少停电时间和损失。 其他说明:该方法不仅在理论上进行了深入探讨,还提供了完整的Python代码实现,便于读者理解和实践。此外,文中还讨论了行波理论的核心公式、三相线路行波解耦、行波测距实现等关键技术点,并针对工程应用给出了注意事项,如波速校准、采样率要求、噪声处理等。这使得该方法不仅具有学术价值,也具有很强的实际应用前景。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值