浙大2013复试:PAT 1056. Mice and Rice (25)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NGwinners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wiis the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5
题意如果读明白了,其实就是比赛的模拟,胜利者进入下一轮,失败者的排名相同,最后输出各个mice的最终排名。注意inital playing order代表的意思是比赛的次序,即前m个序号的mice在一起比,下一组m个序号的mice在一起比等等。采用队列,可以很方便的模拟出最终的排名。

代码如下:

#include<iostream>
#include<queue>
#include<algorithm>
#include<vector>
using namespace std;
int mice[1000];
int r[1000];
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("D:\\in.txt", "r", stdin);
    freopen("D:\\out.txt", "w", stdout);
#endif
    int n(0), m(0);
    cin >> n >> m;
    for (int i = 0; i < n; i++)
    {
        cin >> mice[i];
    }
    queue<int> order;
    int t(0);
    for (int i = 0; i < n; i++)
    {
        cin >> t;
        order.push(t);
    }
    while(order.size() != 1)
    {
        int gamecount = order.size() / m + (order.size() % m == 0 ? 0 : 1);
        int curank = gamecount + 1;//这一轮比赛失败者的排名
        queue<int> tmp;
        for (int i = 0; i < gamecount; i++)
        {
            int max = -1;
            int maxindex = -1;
            for (int j = i*m; j < i*m + m&&order.size()!=0; j++)//如果不满m个,需要判断order.size()!=0
            {
                int index = order.front();
                order.pop();
                if (mice[index]>max)
                {
                    max = mice[index];
                    if (maxindex != -1)
                    {
                        r[maxindex] = curank;
                    }
                    maxindex = index;
                }
                else
                {
                    r[index] = curank;
                }
            }
            tmp.push(maxindex);//一小组比赛结束后,把胜利者的序号放入队列
        }
        order = tmp;
    }
    r[order.front()] = 1;
    cout << r[0];
    for (int i = 1; i < n; i++)
    {
        cout << " " << r[i];
    }
    cout << endl;
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值