Description
My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655
题目的意思是有f+1个人分n个派,每个人的派都要是一个派里面的,就是说不能从几个派分割出来凑。
直接从0到最大的派的面积进行二分,一直到题目要求的精度。
注意PI取acos(-1.0)。
代码如下:
#include<iostream>
#include<iomanip>
#include<cmath>
#include<algorithm>
#define MAXN 10000+10
#define PI acos(-1.0)
#define EXP 1e-6
using namespace std;
int a[MAXN];
int find(double s,int n, int f)
{
int sum = 0;
for(int i = 0; i < n; i++)
{
sum += int(PI * a[i] * a[i] / s);
}
//cout << sum << " " << s << endl;
if(sum < f)
return 1;
return -1;
}
double bs(double max_s, int n, int f)
{
double lo = 0, hi = max_s;
double mi, ans = hi + 1;
while(lo + EXP < hi)
{
mi = (lo + hi) / 2;
if(find(mi, n, f) == 1)
{
hi = mi;
if(ans = hi + 1)
ans = hi;
ans = max(ans,hi);
}
else
{
lo = mi;
ans = min(ans, hi);
}
//cout << lo << " " << hi << endl;
}
if(ans == max_s + 1)
return -1;
return ans;
}
int main()
{
int t;
int n,f;
double max_s;
cin >> t;
while(t--)
{
cin >> n >> f;
f = f + 1;
for(int i = 0; i < n; i++)
cin >> a[i];
sort(a, a+n);
max_s = PI * a[n-1] * a[n-1];
cout << fixed << setprecision(4) << bs(max_s, n, f) << endl;
}
return 0;
}