二分(POJ - 3273 )

本文介绍了一种通过二分查找算法来帮助农夫约翰规划其农场开销的方法。目标是将连续的N天开销分为M个连续段,使得最高开销的那段时间的总额最小。文章提供了一个C++实现案例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >




Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.


题意:给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值。

思路:看到各组最小和最大的,果断上二分。


代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<map>
#include<string>
using namespace std;
typedef long long ll;
typedef double db;
const int MAXN=1e9+10;
const int MAX=1e6+10;
int num[MAX],n,m;
int judge(int val)//判断当前的val之能把天数分成几组 
{
	int i;
	int sum=0,cnt=1;//开始时候把所有的天数都分为一组 
	for(int i=1;i<=n;i++){
		if(sum+num[i]<=val)
			sum=sum+num[i];
		else 
		{
			cnt++;
			sum=num[i]; 
		} 
	} 
	if(cnt>m)return 0;
	else return 1;
}
int main()
{
	scanf("%d%d",&n,&m);
	int low=0,high=0,mid;
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&num[i]);
		low = max(low,num[i]); //最低下限 毕竟每一个月都是要花钱的
							   //那么就需要按照最坏的情况来考虑便是 
		high+=num[i];
	}
	while(low<=high)
	{
		mid=(high+low)>>1;
		if(judge(mid))
			high=mid-1;
		else low=mid+1;
	 } 
	cout<<mid<<endl;
	return 0;
}

转载来自



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值