Lake Counting
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 41344 | Accepted: 20507 |
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12 W........WW. .WWW.....WWW ....WW...WW. .........WW. .........W.. ..W......W.. .W.W.....WW. W.W.W.....W. .W.W......W. ..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source
AC代码:
#include<cstdio>
#include<cstring>
using namespace std;
char field[200][200];
int N,M;
void dfs(int i, int j){
//将 当前位置 W 替换为 .
field[i][j] = '.';
//遍历8个方向
for(int dirx =-1;dirx <= 1; dirx++)
for(int diry =-1; diry <= 1; diry++){
int row = i + dirx;
int col= j + diry;
//row, col 在园子范围内且 filed[row][col] 位置有积水
if((row >= 0 && row < N) && (col >= 0 && col < M) && (field[row][col]=='W')){
dfs(row, col);
}
}
}
int main(){
scanf("%d%d",&N,&M);
getchar();
for(int i = 0; i < N; i++){
gets(field[i]);
}
int res = 0;
//遍历园子每一个位置
for(int i = 0; i < N; i++)
for(int j = 0; j < M; j++){
if(field[i][j]=='W'){
res++;
dfs(i, j);
// printf("%d %d\n", i, j);
}
}
printf("%d\n",res);
return 0;
}