杭电acm1002A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 219914    Accepted Submission(s): 42256


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
C++程序
#include <iostream>
#include <string>

using namespace std;

int main()
{
    char a[1000],b[1000],c[1001];			//定义字符串数组
    int i,j=1,n1,n2,T,p=0;				//p为进位标志
    cin>>T;
    while (T--)
    {
        cin>>a>>b;
        n1=strlen(a)-1;
        n2=strlen(b)-1;
        for (i=0;n1>=0||n2>=0;i++,n1--,n2--)		//字符串逆序相加
        {
            if (n1>=0&&n2>=0)
            {
                c[i]=a[n1]+b[n2]-'0'+p;
            }
            if (n1>=0&&n2<0)				//当数组1长度大于数组2时
            {
                c[i]=a[n1]+p;
            }
            if (n1<0&&n2>=0)				//当数组2长度大于数组1时
            {
                c[i]=b[n2]+p;
            }
            p=0;
            if (c[i]>'9')
            {
                c[i]=c[i]-10;
                p=1;
            }
        }
        cout<<"Case "<<j<<":"<<endl;
        cout<<a<<" + "<<b<<" = ";
        if (p==1)
            cout<<p;					//若有进位,则输出
        while (i--)
        {
            cout<<c[i];
        }
        j++;
        if (T>=1)
            cout<<endl<<endl;
        else
            cout<<endl;
    }
    return 0;
}

刚开始用C++,有很多不足,希望多多吐槽!!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值