A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a family member, K
(>0) is the number of his/her children, followed by a sequence of two-digit ID
's of his/her children. For the sake of simplicity, let us fix the root ID
to be 01
. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
题意:求树中哪一层的孩子节点最多,输出孩子节点个数和这一层的深度。
思路:dfs或bfs
代码:
#include <bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define drep(i,n,a) for(int i=n;i>=a;i--)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e2+5;
int cnt[N],depth[N];
vector<vector<int> >g;
/**dfs */
void dfs(int root,int dep){
cnt[dep]++;
for(auto child:g[root])
dfs(child,dep+1);
}
int main(){
int n,m,id,k;
scanf("%d%d",&n,&m);
g.resize(n+1);
for(int i=0;i<m;i++){
scanf("%d%d",&id,&k);
for(int j=0;j<k;j++){
int x;
scanf("%d",&x);
g[id].push_back(x);
}
}
int root=1;
dfs(root,1);
/** ///bfs
queue<int>que;
que.push(root);
depth[root]=1;
while(!que.empty()){
root=que.front();
que.pop();
cnt[depth[root]]++;
for(auto child: g[root]){
depth[child]=depth[root]+1;
que.push(child);
}
}
**/
int maxSum=0,ansDepth;
for(int i=0;i<=100;i++){
if(maxSum<cnt[i]){
maxSum=cnt[i];
ansDepth=i;
}
}
printf("%d %d", maxSum,ansDepth);
return 0;
}