Catch That Cow
Time Limit: 2000MS Memory limit: 65536K
题目描述
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
输入
Line 1: Two space-separated integers: N and K
输出
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
示例输入
5 17
示例输出
4
提示
//本题的意思大概是:FJ在N,奶牛在K,可以通过三种方法抓到奶牛。1.到现在位置的2倍的位置2.到现在位置的下一个位置3.到现在位置的前一个位置。使用方法BFS来做。
#include<bits/stdc++.h>
#include<queue>
using namespace std;
int n;
int k;
const int N=1000000;
int vis[N+10];
struct node
{
int x,step;
};
int check(int x)
{
if(x<0||x>=N||vis[x])
return 0;
else return 1;
}
int BFS(int x)
{
queue<node>q;
struct node a,next;
a.x=x;
a.step=0;
vis[x]=1;
q.push(a);
while(!q.empty())
{
a=q.front();
q.pop();
if(a.x==k)
return a.step;
next.x=a.x+1;
if(check(next.x))
{
next.step=a.step+1; //操作的次数
vis[next.x]=1;
q.push(next);
}
next.x=a.x-1;
if(check(next.x))
{
next.step=a.step+1;
vis[next.x]=1;
q.push(next);
}
next.x=a.x*2;
if(check(next.x))
{
next.step=a.step+1;
vis[next.x]=1;
q.push(next);
}
}
return -1;
}
int main()
{
int o;
while(~scanf("%d%d",&n,&k))
{
memset(vis,0,sizeof(vis));
o=BFS(n);
printf("%d\n",o);
}
return 0;
}