杭电——Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6

我的代码竟然没有AC,检查了很多遍还是没找出bug:

#include <stdio.h>
#include <stdlib.h>

/************************************************************************/
/* 没有AC,?????????                                           */
/************************************************************************/
void CountMax(int *array, int index, int N)
{
	int startIndex,endIndex;
	int maxsum = 0;
	int sum = 0;
	startIndex = 0;
	for (int i = 0; i < N; i++)
	{
		sum += array[i];
		if(sum > maxsum)
		{
			endIndex = i;
			maxsum = sum;
		}
		if(sum < 0)
		{
			sum = 0;
			startIndex = i+1;
		}
	}
	printf("Case %d:\n",index);
	printf("%d %d %d\n",maxsum,startIndex+1,endIndex+1);
}
int main()
{
	int T;//number of case
	int N;//numbers
	int i,j;
	scanf("%d",&T);
	for (i = 1; i <= T; i++)
	{
		scanf("%d",&N);
		int *arraynum = (int*)malloc(N*sizeof(int));
		for (j = 0; j < N; j++)
		{
			scanf("%d",&arraynum[j]);
		}
		CountMax(arraynum,i,N);
	}

	return 0;
}

下面附上别人AC的代码,请高手指出我的错。

#include<iostream>  
using namespace std;  
#define Min -999999  
int main()  
{  
	int data[100000],start,end;  
	int m;  
	int step=1;  
	cin>>m;      
	while(m--)  
	{  
		int n;  
		cin>>n;  
		for (int i=1; i<=n;i++)  
			cin>>data[i];  
		int max = Min;  
		int k=1;  
		int sum = 0;  
		for (int i=1; i<=n; i++)  
		{  
			sum = sum + data[i];  
			if (sum > max)  
			{  
				max = sum;  
				start=k;  
				end=i;  
			}  
			if(sum<0)  
			{  
				sum=0;  
				k=i+1;  
			}  
		}  
		if(step!=1)  
			cout<<endl;  
		cout<<"Case "<<step<<":"<<endl;  
		cout<<max<<" "<<start<<" "<<end<<endl;  
		step++;  
	}  
	return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值