Moving Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9950 Accepted Submission(s): 3389
Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30
Source
HDU1050
大概题意:输入一组数,搬桌子,走廊两边各有200个房间,要从s房间搬到t房间,走廊一次只能走一张桌子,找一种方案是用时最短
解题思路形成过程:通过参考课件,以及在网上搜索答案获得思路,解题的关键是贪心算法,主要思路是:
#include<algorithm>
#include<string>
#include<sstream>
#include<vector>
#include<numeric>
#include<cmath>
#include<cstdlib>
#include<set>
#include<map>
#include<queue>
#include<stdio.h>
#include<string.h>//尽管我后来知道了并不需要这么多头文件


using namespace std;
int main()
{
int a[201];
int T,N,s,t,m,i,j,b,c;
cin>>T;
for (c=0;c<T;c++)
{
cin>>N;
memset (a,0,sizeof (a));
m=0;
for(b=0;b<N;b++)
{
cin>>s>>t;
s=(s-1)/2;
t=(t-1)/2;
if (s>t)
swap (s,t);
for (i=s;i<=t;i++)
{
a[i]+=1;
}
}
for (j=0;j<200;j++)
{
if (a[j]>m)
m=a[j];
}
cout<<m*10<<endl;
}
return 0;
}