http://www.elijahqi.win/archives/395
Oulipo
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 41973
Accepted: 16865
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
Source
BAPC 2006 Qualification
从0开始编号真的真的不那么好想(#°Д°)
利用kmp就是缩短匹配完i再去匹配i+1的复杂度
利用while循环保证j>1 当匹配成功是不是跳出循环,而是直接按最后一个字符失配的情况去滑动模式串,以获取下一个可能出现的匹配
#include<cstdio>
#include<cstring>
#define N 1100000
#define N1 11000
int next[N],ans,n;
char t[N],w[N1];
int main(){
freopen("poj3461.in","r",stdin);
// freopen("poj3461.out","w",stdout);
scanf("%d",&n);
while (n--){
scanf("%s",w);scanf("%s",t);
int n1=strlen(t),m=strlen(w);
int i=0,j=-1;next[0]=-1;
while (i<n1){
if (j==-1||t[i]==t[j]){
++i;++j;next[i]=j;
}else j=next[j];
}
j=0;int j1;ans=0;
for (int i=0;i<n1;++i){
while (j&&t[i]!=w[j]) j=next[j];
if(t[i]==w[j])++j;
if (j==m) ans++;
}
printf("%d\n",ans);
}
return 0;
}