BGP协议和报文类型简述

【HCIP学习】BGP对等体组、聚合、路由反射器、联盟、团体属性 (1)AS_PATH:解决AS之间的环路问题(2)IBGP的水平分割:解决一个AS内部IBGP邻居之间环路问题(3)当一个反射群中存在多个反射器时,通过Cluster-list防环,(BGP反射器)(4)在多个反射群之间,通过originator_ID防环,(BGP反射器)9、注意事项反射路由无法使用策略去更改路由属性10、实验配置[R2-bgp]peer 3.3.3.3 reflect-client //在反射器上配置其反射客户机。 阅读详情
BGP 概述
  • 边界网关协议(Border Gateway Protocol,BGP)是一种实现自治系统 AS 之间的路由可达,并选择最佳路由的矢量性协议。早期发布的三个版本分别是 BGP-1(RFC1105)、BGP-2(RFC1163)和 BGP-3(RFC1267),1994年开始使用 BGP-4(RFC1771),2006年之后单播 IPv4 网络使用的版本是 BGP-4(RFC4271),其他网络使用的版本是 MP-BGP(RFC4760)。

  • BGP 的特点:

    • BGP 能够承载大批量的路由信息,能够支撑大规模网络。

    • BGP 提供了丰富的路由策略,能够灵活的进行路由选路,并能指导邻居按策略发布路由。

    • BGP 能够支撑 MPLS/VPN 的应用,传递客户 VPN 路由。

    • BGP 提供了路由聚合和路由衰减功能用于防止路由振荡,有效提高了网络的稳定性。

    • BGP 使用 TCP 作为其传输层协议(端口号为179),并支持 BGP 与 BFD 联动、BGP Tracking、BGP Auto FRR 和 BGP GR 和 NSR,提高了网络的可靠性。

BGP 的路径矢量特征
  • BGP 通常被称为路径矢量路由协议(Path-Vector Routing Protocol)。

  • 每天 BGP 路由都携带着多种路径属性(Path attribute),在各种路径属性中,AS_Path 属性是非常关键的一个。AS_Path 属性记录了 BGP 路由传递过程中所经过的 AS 号,实际上它是一个 AS 号的列表。

  • BGP 路由不接受 AS_Path 中包含其自身 AS 号的路由更新。AS_Path 属性值的长短(AS 号的个数)会作为一个比较的依据,影响 BGP 路由选择的决策。

BGP 协议特征
  • BGP 使用 TCP 为传输层协议,TCP 端口号179。路由器之间的 BGP 会话基于 TCP 连接而建立。

  • 运行 BGP 的路由器被称为 BGP 发言者(BGP Speaker),或 BGP 路由器。

  • 两个建立 BGP 会话的路由器互为对等体(Peer)。BGP 对等体之间交换 BGP 路由表。

  • BGP 路由器只发送增量的 BGP 路由更新,或进行触发更新(不会周期性更新)。

  • BGP 具有丰富的路径属性和强大的路由策略工具。

  • BGP 能够承载大批量的路由前缀,用于大规模的网络中。

BGP 报文类型

image.png

image.png

BGP 的状态机

image.png

BGP Peer
  • 运行 BGP 的路由器被称为 BGP 发言者,或者 BGP 路由器。

  • BGP 对等体也叫 BGP 邻居,与 OSPF、RIP等协议不同,BGP 的会话是基于 TCP 建立的。建立 BGP 对等体关系的两台路由器并不要求必须直连。

  • BGP 存在两种对等体关系类型:EBGP及IBGP。针对这两种对等体类型,BGP 处理路由的操作存在较大差异。

  • EBGP(External BGP):位于不同自治系统的 BGP 路由器之间的 BGP 邻接关系。

    • 两台路由器之间要建立 EBGP 对等体关系,必须满足两个条件:

      • 两个路由器所属 AS 不同(也即 AS 号不同)。

      • 在配置 BGP 时,Peer 命令所指定的对等体 IP 地址要求路由可达,并且 TCP 连接能够正确建立。

  • IBGP(Internal BGP):为相同自治系统的 BGP 路由器之间的 BGP 邻接关系。

    • 两台路由器之间要建立 IBGP 对等体关系,必须满足两个条件:

      • 两个路由器所属 AS 需相同(也即 AS 号相同)。

      • 在配置 BGP 时,Peer 命令所指定的对等体 IP 地址要求路由可达,并且 TCP 连接能够正确建立。

一、BGP协议原理 BGP基本原理 阅读详情

相关推荐

BGP协议原理(一)BGP协议基本概念:BGP作用与特点、BGP邻居关系建立与配置

文章目录前提概念BGP的基本作用BGP协议特点BGP邻居关系和配置报文类型:BGP的简单连接配置 前提概念 IGP:内部网关路由协议:OSPF、RIP、IS-IS EGP:外部网关路由协议:BGP BGP:外部网关路由协议代表 AS概念区别:IGP中,AS概念与EGP中概念。 IGP中AS:同一协议:使用同一种路由协议交换路由信息。 EGP中AS:泛化了。:一个企业中可能不只是用一种路由协议。 B...

Skye's Blog 1万+

第七章 BGP 

此系列文章是以邮电出版社的华为HCNP路由交换学习指南为提纲,经过总结整理的学习笔记。另外此系列文章仅作为交流学习使用,请勿转载。

qq_42231703的博客 2403

BGP协议总结

概述 BGP为Border Gateway protocol 边界网关路由协议(路径矢量) 主要作用是在AS之间传递路由信息 • 分类:EGP • 工作机制:路径矢量协议 • 无类路由协议:支持VLSM和CIDR • 应用层协议/7层,TCP封装,179端口号 • IGP使用networks通告路由,用度量值标识路径好坏 • BGP通告整条路径,并使用属性标识路径好坏 • BGP可通过各种路由策略...

weixin_44132032的博客 1万+

BGP知识点

BGP速成大法

小翟的博客 4133

动态路由协议BGP基本原理和基础配置(BGP+RIP+OSPF实验)

文章目录前言一、BGP概述1.1BGP简介1.2BGP的特征1.3各路由协议的分类二、BGP工作原理2.1BGP报文2.2BGP数据库2.3BGP的类型三、BGP协议的配置3.1配置思路3.2配置实验3.2.1拓扑图3.2.2配置步骤3.2.3各路由器配置3.2.4测试 前言 边界网关协议(BGP)是运行于 TCP 上的一种自治系统的路由协议。 BGP 是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。 BGP 构建在 EGP 的经验之上。 BGP 系统的主要

weixin_47153988的博客 5739

BGP报文格式详解

BGP边界网关路由协议 一、BGP协议概述 使用范围:BGP范围,使用在AS之间的路由协议 协议的特点:路径矢量型(高级的距离矢量型),没有具体的协议算法,要说非得有个算法的话,那么人就是最好的BGP协议的算法 是否携带网络掩码:携带,并且支持VLSM、CIDR 数据包的封装:基于TCP封装,端口号179 AS:自制系统 AS的分类:公有AS和私有AS,公有AS的范围是1-64511,私有AS的范围是64512-65535 二、BGP协议的特点 1、BGP协议是一种路径矢量型路由协议 2、BGP协议的版本:

qq_43560395的博客 4845

网络基础BGP-IBGP-EBGP

文章目录BGPAS的概念BGP概述BGP的路径矢量特征BGP协议特征BGP报文类型BGP状态机BGP PeerIBGP水平分割规则BGP路由通告规则BGP相关的几张表 BGP AS的概念 自治系统(Autonomous System,AS),指的是在同一个组织管理下,使用相同策略的设备的集合。 不同的AS通过AS号区分,AS号取值范围1-65535,其中64512-65535是私有AS号。IANA负责AS号的分发。 中国电信163 AS号:4134 中国电信CN2 AS号:4809 中国网通AS 号:99

qq_35479765的博客 2126

5.BGP

早期发布的三个版本分别是BGP-1(RFC1105)、BGP-2(RFC1163)和BGP-3(RFC1267),1994年开始使用BGP-4(RFC1771),2006年之后单播IPv4网络使用的版本是BGP-4(RFC4271),其他网络(如IPv6等)使用的版本是MP-BGP(RFC4760)。本章只讨论BGP-4。该状态下,BGP 等待完成 TCP 连接,若连接成功,则向对等体发送 Open 消息,然后进入OpenSent状态:如果连接失败,则继续侦听是否有对等体启动连接并进入 Active状态。

lwljh134的博客 873

BGP

一、BGP概述 1、自治系统AS 由同一个技术管理机构管理、使用统一选路策略的一些路由器的集合。 2、BGP路由协议的特点 1.BGP能够承载大批量的路由信息,能够支撑大规模网络。 2.BGP使用TCP作为其传输层协议(监听端口号为179),提高了协议的可靠性。 3.BGP是外部路由协议,用来在AS之间传递数据,对稳定性要求非常高。因此用TCP协议的高可靠性来保证BGP协议的稳定性。 4.BGP的对等体之间必须逻辑上连通,并进行TCP连接。目的端口号为179,本地端口号任意。 5.BGP对等体和IGP对等体

weixin_55609951的博客 483

BGP 技术连载:NSR技术,一种控制平面倒换而邻居不感知的可靠性技术

BGP NSR(BGP Non-Stop Routing)是一种网络协议功能,旨在确保在路由器重启过程中BGP会话不中断。这种功能对于网络的稳定性和可靠性至关重要。本文将深入探讨BGP NSR的原理、工作机制以及实现细节。

网络技术联盟站 1262

rfc4760-中文版.pdf

本文档定义了BGP-4的扩展,使其能够携带多种网络层协议的路由信息(如IPv6,IPX,L3等)。扩展是向后兼容的 - 支持扩展的路由器可以与不支持扩展的路由器互操作。

BGP——图解5种报文

例如:当BGP的入口路由策略发生变化时,可以通过手动触发请求邻居重新通告路由,对BGP路由表进行动态刷新。Optional Parmeters可变长字段,用于携带BGP邻居会话协商过程中使用的可选字段。1.Marter:检查BGP对等体的同步信息是否完整,不使用此验证时所有比特均为1。可变长字段,被包含在BGP路由更新中,携带路由的前缀和掩码信息。每个属性由可变长的三元组(属性类型、属性长度、属性值)组成。----此处指的就是Open报文。----此处就是不使用此验证。----长度为19~4096。

m0_49864110的博客 2万+

Anaconda启动失败,一直在loading application的问题

实战基础新的改变功能快捷键合理的创建标题,有助于目录的生成如何改变文本的样式插入链接与图片如何插入一段漂亮的代码片生成一个适合你的列表创建一个表格设定内容居中、居左、居右SmartyPants创建一个自定义列表如何创建一个注脚注释也是必不可少的KaTeX数学公式新的甘特图功能,丰富你的文章UML 图表FLowchart流程图导出与导入导出导入 你好! 这是你第一次使用 Markdown编辑器 所展示的欢迎页。如果你想学习如何使用Markdown编辑器, 可以仔细阅读这篇文章,了解一下Markdown的基本

Tristan的博客 2771

BGP协议

1.AS(autonomous system)自治系统(BGP一个路由器只能处于一个AS) AS是指在一个实体管辖下的拥有相同选路策略的IP网络。BGP网络中的每个AS都被分配一个唯一的AS号,用于区分不同的AS。AS号分为2字节AS号和4字节AS号,其中2字节AS号的范围为1至65535,4字节AS号的范围为1至4294967295。支持4字节AS号的设备能够与支持2字节AS号的设备兼容。 IG...

WluoW的博客 1万+

树莓派5搭建ROS1开发环境:从系统安装到环境变量配置

本文详细指导如何在树莓派5上搭建ROS1开发环境。针对树莓派OS非标准安装路径导致的常见CMake报错问题,提供了从系统烧录、一键安装ROS到关键环境变量配置的完整解决方案,确保工作空间能成功编译,助力机器人项目开发。

weixin_29159127的博客 384

SoapUI 5.0 模拟WebService接口实战:从WSDL文件到Mock服务端完整流程

本文详细介绍了如何使用SoapUI 5.0模拟WebService接口,从解析WSDL文件到搭建完整的Mock服务端流程。通过实战案例和效率技巧,帮助开发者快速掌握接口模拟技术,提升开发与测试效率。

weixin_26833139的博客 405

网络协议——BGP(边界网关协议)全网最详解

AS: 指的是在同一个组织管理下,使用统一选路策略的设备集合,AS取值范围四字节( 0~43亿。

wh940830165的博客 2万+

Windows非分页缓冲池内存泄漏实战:PoolMon与RAMMap高效排查指南

本文详细介绍了Windows系统中非分页缓冲池内存泄漏的实战排查方法。当系统出现卡顿且内存占用异常增长时,通过RAMMap工具快速定位非分页缓冲池异常,并利用PoolMon监控内核内存分配标签,精准锁定泄漏源。文章提供了从确认症状、安装工具到使用findstr命令溯源驱动文件的完整五步排查流程,并总结了常见泄漏标签与解决方案,帮助用户高效解决深层系统内存问题。

weixin_28455801的博客 1008

BGP路由协议(二):报文的类型和格式

当两台需建立对等体关系的BGP路由器完成配置后,双方需首先建立TCP连接,TCP连接建立完成后双方开始交换Open报文,如果一方认可对方发送过来的Open报文,则使用Keepalive报文进行回应。如果路由器收到了BGP对等体发来的、用于确认自己先前发送的Open报文的Keepalive报文,这意味着对方已经认可了自己所发的Open报文中的相关参数,则该路由器认为已经与对方完成了BGP对等体关系建立,此时双方便可以开始交互Update报文,而Update报文中便包含路由器所通告的路由信息。

jlgkeep的博客 1011

【Flink cdc】Data row is smaller than a column index, internal schema representation is probably xxx

翻译一下:当scan.startup.mode=EARLIEST_OFFSET时,如果在最早的offset之后表结构有过变化就无法支持。原因应该是在binlog 的earliest_offset之后,表结构被修改过。我的解决方案:source配置中使用。mysql source配置使用。,以时间戳为消费依据。

integrity 2084

银河麒麟操作系统最佳实践专栏介绍

本专栏聚焦国产银河麒麟操作系统(桌面版/服务器版)的实战应用,提供系统安装、配置优化、应用部署、故障排查等实用指南。内容基于真实操作场景,涵盖Linux通用技术(如RAID配置、环境变量管理)、服务器系统专项(如数据库迁移、驱动安装、安全加固)及桌面系统技巧(如PXE安装、镜像封装)。面向IT运维、开发者和国产化转型人员,突出实战性和差异化,帮助用户规避常见问题,提升系统管理效率。所有教程均配有详细步骤和截图,确保可操作性,并持续更新适配新版系统。

信创运维工程师 · 银河麒麟 & 容器实战 | 金融生产环境迁移·等保加固 | 142篇原创·17万+阅读 530

BGP的5种报文类型

一条Update报文可以通告一类具有相同路径属性的可达路由,这些路由放在NLRI(Network Layer Reachabl Information,网络层可达信息)字段中,Path Attributes字段携带了这些路由的属性,BGP根据这些属性进行路由的选择。BGP-4协议有5种报文:Open(建立)、Update(更新)、Notification(通知)、Keepalive(保持活跃)和Route-refresh(路由刷新),其中Keepalive报文为周期性发送,其余报文为触发式发送。

Fanmeang的博客 1521

couldn‘t upgrade db schema: insert into ACT_GE_PROPERTY values (‘common.sche[已解决]

启动整合了flowable的项目,初始化时报错。flowable没有自动建表, 原因 测试数据库版本是MySQL5.7。经过查询和尝试,原因是:在这个数据库里面,已经有一个数据库里面有activiti的这些表了,它检索的时候全库检索查到它了,所以flowable不去建表了,但是我们指定的这个schema里卖弄还是空的,所以它报了找不到表。解决方法:mysql的链接上加上参数如下,让本schema成为默认的schema。...

JavaPub 6003

BGP报文分析 及 BGP路由属性

针对 BGP的五种报文进行详细的分析

m0_63121194的博客 3233

Camera2Demo

在Camera2 的基础上进行封装,使得Camera2一堆初始化逻辑与Activity分离,降低耦合度,完成预览拍照并保存的操作

廖雪峰Python教程[完整版]

廖雪峰的python教程整理的,已经排好版了,而且还是完整的,适合小白

BGP - 32张图详解BGP路由协议:BGP基本概念、BGP对等体、BGP报文类型、BGP状态机等

32张图详解BGP路由协议:BGP基本概念、BGP对等体、BGP报文类型、BGP状态机等

StudyMaterials的博客 3425

蓝牙模块HM-10手册

蓝牙模块HM-10手册,该手册对蓝牙模块HM-10进行了详细的介绍和使用方法以及一些AT指令。

上一篇: Go语言Gin框架+Gorm实战CRUD
下一篇: 实现clickhouse-logger自定义请求头存储
云开发者联盟
博客等级 码龄5年 546粉丝 93原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

个

红包个数最小为10个

元

红包金额最低5元

当前余额3.43元 前往充值 >
需支付:10.00元
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值