1029. Median (25)

本文介绍了一种算法,该算法能够接收两个递增的整数序列,并找出这两个序列合并后的中位数,同时确保合并过程中去除重复元素。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

原题地址:http://www.patest.cn/contests/pat-a-practise/1029

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13

解题思路:注意两个序列合并后,重复数字要剔除。

代码如下:

#include <stdio.h>
#include <algorithm>
#include <stdlib.h>
#include <cstring>
#define MAXN 1000005

using namespace std;

int N1,N2;
long int sq[MAXN*2];
long int sq1[MAXN];
long int sq2[MAXN];

/*
int cmp(const void*_a, const void*_b){
    long int a = *(long int *)_a;
    long int b = *(long int *)_b;
    return a > b;   
}
*/

int main(){
    freopen("1029.txt","r",stdin);

    memset(sq,-1,sizeof(sq));
    scanf("%d", &N1);
    for(int i = 0; i < N1; i++) 
        scanf("%ld", &sq1[i]);
   scanf("%d", &N2);
    for(int i = 0; i < N2; i++)
        scanf("%ld", &sq2[i]);

    int p = 0, q = 0;
    int count = 0;
    while(p < N1 || q < N2){
        if(p >= N1){
            if(count == 0) {sq[count++] = sq2[q]; q++;}
            else if(sq[count-1] == sq2[q]) q++;
            else {sq[count++] = sq2[q]; q++; }
        }else if( q >= N2){
            if(count == 0) {sq[count++] = sq1[p]; p++;}
            else if(sq[count-1] == sq1[p]) p++;
            else {sq[count++] = sq1[p]; p++; }
        }else{
        if(sq1[p] < sq2[q]){
            if(count == 0) {sq[count++] = sq1[p]; p++;}
            else if(sq[count-1] == sq1[p]) p++;
            else {sq[count++] = sq1[p]; p++; }
        }else if(sq1[p] > sq2[q]){
            if(count == 0) {sq[count++] = sq2[q]; q++;}
            else if(sq[count-1] == sq2[q]) q++;
            else {sq[count++] = sq2[q]; q++; }
        }else{
            if(count == 0) {sq[count++] = sq2[q]; q++; p++;}
            else if(sq[count-1] == sq2[q]) { q++; p++;}
            else {sq[count++] = sq2[q]; q++; p++; }
        }
        }
    }
//  printf("%d\n",count);
//  for(int i = 0; i<count;i++ ) printf("%ld \n", sq[i]);
    printf("%ld\n",sq[(count*10-5)/20]);
    return 0;
}
分析下列代码作用,用for循环达成效果 代码如下: df_cleanID['是否吃大米'].median() df_cleanID['平均每次食用量'].median() df_cleanID['是否吃小麦面粉'].median() df_cleanID['平均每次食用量.1'].median() df_cleanID['是否吃杂粮'].median() df_cleanID['平均每次食用量.2'].median() df_cleanID['是否吃薯类'].median() df_cleanID['平均每次食用量.3'].median() df_cleanID['是否吃油炸面食'].median() df_cleanID['平均每次食用量.4'].median() df_cleanID['是否吃猪肉'].median() df_cleanID['平均每次食用量.5'].median() df_cleanID['是否吃牛羊肉'].median() df_cleanID['平均每次食用量.6'].median() df_cleanID['是否吃禽肉'].median() df_cleanID['平均每次食用量.7'].median() df_cleanID['是否吃内脏类'].median() df_cleanID['平均每次食用量.8'].median() df_cleanID['是否吃水产类'].median() df_cleanID['平均每次食用量.9'].median() df_cleanID['是否吃鲜奶'].median() df_cleanID['平均每次食用量.10'].median() df_cleanID['是否吃奶粉'].median() df_cleanID['平均每次食用量.11'].median() df_cleanID['是否吃酸奶'].median() df_cleanID['平均每次食用量.12'].median() df_cleanID['是否吃蛋类'].median() df_cleanID['平均每次食用量.13'].median() df_cleanID['是否吃豆腐'].median() df_cleanID['平均每次食用量.14'].median() df_cleanID['是否吃豆腐丝等'].median() df_cleanID['平均每次食用量.15'].median() df_cleanID['是否吃豆浆'].median() df_cleanID['平均每次食用量.16'].median() df_cleanID['是否吃干豆'].median() df_cleanID['平均每次食用量.17'].median() df_cleanID['是否吃新鲜蔬菜'].median() df_cleanID['平均每次食用量.18'].median() df_cleanID['是否吃海草类'].median() df_cleanID['平均每次食用量.19'].median() df_cleanID['是否吃咸菜'].median() df_cleanID['平均每次食用量.20'].median() df_cleanID['是否吃泡菜'].median() df_cleanID['平均每次食用量.21'].median() df_cleanID['是否吃酸菜'].median() df_cleanID['平均每次食用量.22'].median() df_cleanID['是否吃糕点'].median() df_cleanID['平均每次食用量.23'].median() df_cleanID['是否吃水果'].median() df_cleanID['平均每次食用量.24'].median() df_cleanID['是否吃果汁饮料'].median() df_cleanID['平均每次食用量.25'].median() df_cleanID['是否吃其他饮料'].median() df_cleanID['平均每次食用量.26'].median()
最新发布
03-30
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值