江苏省赛 JSCPC2018 A. Easy h-index

本文介绍了一道关于计算作者h指数的问题,通过给定发表论文及其引用次数的数据,寻找最大的h值使得作者拥有至少h篇论文每篇被引用不少于h次。文章提供了两种实现思路及代码示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目

A. Easy h-index

The h-index of an author is the largest h where he has at least h papers with citations not less than h. Bobo has published many papers. Given a0,a1,a2,…,an which means Bobo has published ai papers with citations exactly i, find the h-index of Bobo.

Input

The input consists of several test cases and is terminated by end-of-file. The first line of each test case contains an integer n. The second line contains (n+1) integers a0,a1,…,an.

Output

For each test case, print an integer which denotes the result.
Constraint • 1≤ n ≤2·105 • 0≤ ai ≤109 • The sum of n does not exceed 250,000.

Sample Input

1
1 2
2
1 2 3
3
0 0 0 0

Sample Output

1
2
0

题解:

从大到小枚举h即可

总结
  • 当时比赛做的时候,觉得很简单,自己的测试用例都是对的,理解也毫无问题,但就是WR,当看到题解时,内心时崩溃的
  • 让求最大的h,这个h是:bobo发表了至少h篇包含h个引语的文章
  • 我们之前的理解是只能是a[i]>=h && i>=h
  • 题解是sum(a[i])>=h

代码

#include <cstdio>

const int N = 200001;

int a[N];

int main()
{
    int n;
    while (scanf("%d", &n) == 1) {
        for (int i = 0; i <= n; ++ i) {
            scanf("%d", a + i);
        }
        int h = n + 1;
        long long cnt = 0;
        while (cnt < h) {
            cnt += a[-- h];
        }
        printf("%d\n", h);
    }

}

一个便于理解的代码

#include <bits/stdc++.h>

const int N = 200001;

int n, a[N];

bool check(int h)
{
    long long cnt = 0;
    for (int i = h; i <= n; ++ i) {
        cnt += a[i];
    }
    return cnt >= h;
}

int main()
{
    while (scanf("%d", &n) == 1) {
        for (int i = 0; i <= n; ++ i) {
            scanf("%d", a + i);
        }
        int h = n;
        while (!check(h)) {
            h --;
        }
        printf("%d\n", h);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值