杭电1058

本博客探讨了一个特定序列中第n个谦数的查找算法,该序列由仅包含2,3,5,7这四个质因数的整数组成。通过高效的算法实现,用户可以快速找到序列中的任意位置的谦数。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13689    Accepted Submission(s): 5956


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

代码如下:

#include <iostream>
#include <algorithm>
using namespace  std;
#define  N 5842
int values[N + 1] ;

inline int minValue(int n1, int n2, int n3, int n4)
{
	return min(min(n1, n2), min(n3, n4)) ;
}

int main(int argc, char ** argv)
{
	memset(values, 0, ( N + 1 ) * sizeof(int)) ;
	values[1] = 1 ;
	int p1, p2, p3, p4 ;
	p1 = p2 = p3 = p4 = 1 ;
	
	for (int i = 2; i <= N; ++ i)
	{
		values[i] = minValue(values[p1] * 2, values[p2] * 3, values[p3] * 5, values[p4] * 7) ;
		if (values[p1] * 2 == values[i]) p1 ++ ;
		if (values[p2] * 3 == values[i]) p2 ++ ;
		if (values[p3] * 5 == values[i]) p3 ++ ;
		if (values[p4] * 7 == values[i]) p4 ++ ;
	}

	int inValue ;
	while(cin >> inValue && inValue != 0)
	{
		if (inValue % 100 == 11 || inValue % 100 == 12 || inValue % 100 == 13)
			cout << "The "<< inValue << "th humble number is " <<values[inValue]<< "." << endl;
		else	
			if (inValue % 10 == 1)
				cout << "The "<< inValue << "st humble number is " <<values[inValue]<< "." << endl;
			else
				if (inValue % 10 == 2)
					cout << "The "<< inValue << "nd humble number is " <<values[inValue]<< "." << endl;
				else
					if (inValue % 10 == 3)
						cout << "The "<< inValue << "rd humble number is " <<values[inValue]<< "." << endl;
					else
						cout << "The "<< inValue << "th humble number is " <<values[inValue]<< "." << endl;
	}
	return 0 ;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值