题目
Easy Summation
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4006 Accepted Submission(s): 1627
Problem Description
You are encountered with a traditional problem concerning the sums of powers.
Given two integers n and k. Let f(i)=ik, please evaluate the sum f(1)+f(2)+...+f(n). The problem is simple as it looks, apart from the value of n in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo 109+7.
Input
The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
Each of the following T lines contains two integers n(1≤n≤10000) and k(0≤k≤5).
Output
For each test case, print a single line containing an integer modulo 109+7.
Sample Input
3 2 5 4 2 4 1
Sample Output
33 30 10
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6027
思路
大早上水一水,快乐快乐。矩阵快速幂的题,开始一个变量写错了,然后样例都过不了。哎,不多说了。
代码
#include<cstdio>
using namespace std;
typedef long long ll;
const int MOD = 1e9 + 7;
#define mod(x) ((x)%MOD)
ll sum = 0;
ll poww(int a,int b){
ll res = 1,base = a;
while(b){
if(b&1)res = mod(res*base);
base = mod(base*base);
b >>= 1;
}
return res;
}
int main(){
int t,n,k;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&k);
sum = 0;
for(int i=1;i <= n;i++){
sum += poww(i,k);
}
printf("%lld\n",mod(sum));
}
return 0;
}