HDU 6027-Easy Summation

题目

Easy Summation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4006    Accepted Submission(s): 1627


 

Problem Description

You are encountered with a traditional problem concerning the sums of powers.
Given two integers n and k. Let f(i)=ik, please evaluate the sum f(1)+f(2)+...+f(n). The problem is simple as it looks, apart from the value of n in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo 109+7.

 

 

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
Each of the following T lines contains two integers n(1≤n≤10000) and k(0≤k≤5).

 

 

Output

For each test case, print a single line containing an integer modulo 109+7.

 

 

Sample Input

 

3 2 5 4 2 4 1

 

 

Sample Output

 

33 30 10

 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6027

思路

大早上水一水,快乐快乐。矩阵快速幂的题,开始一个变量写错了,然后样例都过不了。哎,不多说了。

代码

#include<cstdio>

using namespace std;

typedef long long ll;

const int MOD = 1e9 + 7;
#define mod(x) ((x)%MOD)

ll sum = 0;
ll poww(int a,int b){
    ll res = 1,base = a;
    while(b){
        if(b&1)res = mod(res*base);
        base = mod(base*base);
        b >>= 1;
    }
    return res;
}

int main(){
    int t,n,k;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);
        sum = 0;
        for(int i=1;i <= n;i++){
            sum += poww(i,k);
        }
        printf("%lld\n",mod(sum));
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yjz6/p/9799605.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值