HDU 1062 字符串处理

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12864    Accepted Submission(s): 4879

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 
Output
For each test case, you should output the text which is processed.
 
Sample Input
3 olleh !dlrow m'I morf .udh I ekil .mca
 
Sample Output
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 
Author
Ignatius.L
 
刚开始用数组预读来做的,结果正确,提交之后出现PE,可是检查了好几次了,都没有检查出来,输出肯定是哪个地方没有控制好,姑且把PE代码贴出来,请各位路过的大神帮忙指点指点,看输出哪里有问题
#include <stdio.h>
#include <string.h>
int main()
{
    int n,i,j;
    
    scanf("%d",&n);
    getchar();//这个是必须的,因为是用gets()函数读入的
    while(n--)
    {
        char a[1001];
        memset(a,0,sizeof(a));
        gets(a);
        int l=strlen(a);
        int t1=0,t2;//用来标记输出的结束和开始位置
        for(i=0;i<l;i++)
            if(a[i]==' ')
            {
                t2=i;
                for(j=t2-1;j>=t1;j--)
                    printf("%c",a[j]);
                t1=i+1;
                printf(" ");
            }
            else if(i==l-1)//结束的时候
            {
                t2=i;
                for(j=t2;j>=t1;j--)
                    printf("%c",a[j]);
                printf("\n");
            }
    }
    return 0;
}
View Code


然后又采用指针来控制位置,下面是AC代码

#include<iostream>
#include <string.h>
#include "stdio.h"
using namespace std;
int main()
{
    int n;
    cin >> n;
    getchar();
    while(n--)
    {
         char a[1001];
         memset(a,0,sizeof(a));
         gets(a);
         char *p ,*q,*k;
         k = q = p = a;

         while(*p!=0)
         {
              int c = 0;
              while(*p == ' ')
              {
                  p++;
                  cout << ' ' ;
              }

              k = p;                    //k标记字母开始的第一个位子
              while(*p!=' ' && *p!=0) //把p移到最后字母的后一个
                 p++;

              q = p;                   //q标记最后一个字符的后一个位子

              p--;                     //倒退一个,p就是标记最后一个字母了,输出全都字母
              while(p>=k)
              {
                   cout << *p;
                   p--;
              }
              p = q;

         }

         cout << endl;
    }

    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/LOB104-zhanglei/articles/3188856.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值