POJ1753——DFS+枚举——Flip Game

本文深入解析了一种名为Flipgame的游戏算法,该游戏在一个4x4的棋盘上进行,玩家的目标是通过翻转棋子,使所有棋子的颜色统一。文章详细介绍了游戏规则,包括如何选择并翻转棋子,以及如何计算最少的翻转次数来达到游戏目标。通过使用C++编程语言,文章提供了一个解决此问题的算法实现,包括状态判断和深度优先搜索策略。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

 

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

大意:翻转一个棋子,周围的棋子也要改变,求最小翻的次数
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[6][6];
int step,flag;
int judge(int a[6][6]){
    for(int i = 1; i <= 4; i++){
            for(int j = 1; j <= 4; j ++){
                    if(a[i][j] != a[1][1])
                     return 0;
            }
    }
    return 1;
}
void fanzhuan(int i,int j){
    a[i][j] = !a[i][j];
    a[i][j+1] = !a[i][j+1];
    a[i][j-1] = !a[i][j-1];
    a[i+1][j] = !a[i+1][j];
    a[i-1][j] = !a[i-1][j];
}
void dfs(int i, int j,int foot){
    if(foot == step)
    {
        flag = judge(a);
        if(flag == 1) return ;
    }
    if(flag||i == 5) return ;
    fanzhuan(i,j);
    if(j<4)
    dfs(i,j+1,foot+1);
    else dfs(i+1,1,foot+1);
    fanzhuan(i,j);
    if(j<4)
    dfs(i,j+1,foot);
    else dfs(i+1,1,foot);
    return ;
}
int main(){
    char t;
    int i,j;
    memset(a,0,sizeof(a));
    for( i = 1; i <= 4 ; i++){
        for( j = 1; j <= 4; j++){
              scanf("%c",&t);
              if(t == 'b') a[i][j] = 1;
        }
        getchar();
    }
    for(step = 0; step<= 16; step++){
        dfs(1,1,0);
        if(flag==1)
            break;
    }
    if(step>16)
        printf("Impossible\n");
    else printf("%d\n",step);
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/zero-begin/p/4313118.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值