继续畅通工程 krusal

本文详细介绍了Krusal算法在最小生成树问题中的应用,特别关注算法中容易忽略的细节,如r的大小计算及先排序的重要性。通过具体案例,展示了如何使用Krusal算法解决实际问题,如计算全省畅通所需最低成本。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

krusal 最小生成树  最最最最简单的!!

但是我一开始总是忘了 把 r 的大小是n*(n-1)/2  WA了好多次!!!

还有记得先排序噢~

View Code
继续畅通工程

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。
Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
Sample Output
3
1
0
View Code
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <queue>
#include <cmath>

using std::sort;

int fa[105];
struct node
{
    int a, b, c, d;
}r[10000];
int find(int t)
{
    if(t == fa[t] )
        return t;
    else
        return fa[t] = find(fa[t]);
}
bool merge(int i)
{
    int fx = find(r[i].a);
    int fy = find(r[i].b);
    if( fx == fy )
        return 0;
    fa[fx] = fy;
    return 1;
}
int cmp(node a, node b)
{    return a.c <= b.c ;  }
int main()
{    
    int i, a, b, c, d, cnt, ans, n;
    while(scanf("%d", &n), n)
    {
        ans = 0, cnt = 0;
        for(i=1; i<=n; i++)
            fa[i] = i;
        for(i=1; i<=n*(n-1)/2; i++)
        {
            scanf("%d %d %d %d", &a, &b, &c, &d);
            r[i].a = a, r[i].b = b, r[i].c = c, r[i].d = d;
            if(d)
                merge(i);
        }
        for(i=1; i<=n; i++)
            if(fa[i] == i )
                cnt++;
        sort( r+1, r+1+n*(n-1)/2, cmp );
        for(i=1; i<=n*(n-1)/2 && cnt > 1; i++)
            if(r[i].d == 0)
            {
                if(merge(i))
                    ans += r[i].c, cnt--;
            }
        printf("%d\n", ans);
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/crisxyj/archive/2013/03/18/2966195.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值