hdu 5821 Ball (贪心)

本文介绍了一种通过排序策略解决球移动问题的方法。该问题要求判断是否可以通过一系列操作将初始状态的球移动到目标状态。文章提供了一个具体的C++实现方案,并详细解释了其背后的逻辑。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Ball

Description

ZZX has a sequence of boxes numbered  1,2,...,n. Each box can contain at most one ball. 

You are given the initial configuration of the balls. For 1 \leq i \leq n, if the i-th box is empty then a[i]=0, otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished. 

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball) 

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal. 

Input

First line contains an integer t. Then t testcases follow. 
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i]. 

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000. 

0<=a[i],b[i]<=n. 

1<=l[i]<=r[i]<=n.

Output

For each testcase, print "Yes" or "No" in a line.

Sample Input

5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4

Sample Output

No
No
Yes
No
Yes

贪心的策略是让A数组中的数更接近正确位置,正确位置是A数组中的数在B数组中出现的第一个未被标记的位置,让数接近正确位置的贪心就是对于每个区间sort。

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1010;
int a[maxn], b[maxn];
int id[maxn];
int main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        int n, m;
        scanf("%d %d", &n, &m);
        memset(id, 0, sizeof(id));
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
        }
        for(int i = 1; i <= n; i++) {
            scanf("%d", &b[i]);
            for(int j = 1; j <= n; j++) {
                if(!id[j] && a[j] == b[i]) {
                    id[j] = i;
                    break;
                }
            }
        }
        for(int i = 1; i <= m; i++) {
            int l, r;
            scanf("%d %d", &l, &r);
            sort(id + l, id + r + 1);
        }
        int flag = 1;
        for(int i = 1; i <= n; i++) {
            if(id[i] != i) {
                flag = 0;
                break;
            }
        }
        if(flag) puts("Yes");
        else puts("No");
    }
}

 

转载于:https://www.cnblogs.com/lonewanderer/p/5767279.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值