hdu 5806 NanoApe Loves Sequence Ⅱ (尺取法)

本文介绍了一个名为NanoApeLovesSequenceⅡ的编程问题,该问题要求找出给定序列中所有长度不小于k的连续子序列,使得这些子序列中的第k大的数不小于给定值m。通过一种滑动窗口的方法实现了问题求解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

NanoApe Loves Sequence Ⅱ

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 500    Accepted Submission(s): 242


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with  n numbers and a number m on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the k-th largest number in the subsequence is no less than m.

Note : The length of the subsequence must be no less than k.
 

 

Input
The first line of the input contains an integer  T, denoting the number of test cases.

In each test case, the first line of the input contains three integers n,m,k.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1T10, 2n200000, 1kn/2, 1m,Ai109
 

 

Output
For each test case, print a line with one integer, denoting the answer.
 

 

Sample Input
1
7 4 2
4 2 7 7 6 5 1
 

 

Sample Output
18
 
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <set>
using namespace std;
#define ll long long
int s[200010];
int main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        ll n,k,t;
        scanf("%I64d %I64d %I64d", &n, &t, &k);
        s[0] = 0;
        for(int i = 1; i <= n; i++) {
            s[i] = s[i-1];
            int tmp;
            scanf("%d", &tmp);
            if(tmp >= t) s[i]++;
        }
        ll beg = 0, end = k, ans = 0;
        while(end <= n) {
            while(s[end] - s[beg] >= k)beg++;
            ans += beg;
            end++; 
        }
        printf("%I64d\n", ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/lonewanderer/p/5745707.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值