hdu 5719 Arrange

Arrange

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 674    Accepted Submission(s): 236


Problem Description
Accidentally, Cupid, god of desire has hurt himself with his own dart and fallen in love with Psyche. 

This has drawn the fury of his mother, Venus. The goddess then throws before Psyche a great mass of mixed crops.

There are  n heaps of crops in total, numbered from 1 to n

Psyche needs to arrange them in a certain order, assume crops on the i-th position is Ai.

She is given some information about the final order of the crops:

1. the minimum value of A1,A2,...,Ai is Bi.

2. the maximum value of A1,A2,...,Ai is Ci.

She wants to know the number of valid permutations. As this number can be large, output it modulo 998244353.

Note that if there is no valid permutation, the answer is 0.
 

 

Input
The first line of input contains an integer  T (1T15), which denotes the number of testcases.

For each test case, the first line of input contains single integer n (1n105).

The second line contains n integers, the i-th integer denotes Bi (1Bin).

The third line contains n integers, the i-th integer denotes Ci (1Cin).
 

 

Output
For each testcase, print the number of valid permutations modulo  998244353.
 

 

Sample Input
2 3 2 1 1 2 2 3 5 5 4 3 2 1 1 2 3 4 5
 

 

Sample Output
1 0
Hint
In the first example, there is only one valid permutation (2,1,3) . In the second example, it is obvious that there is no valid permutation.
 

 

Source
 
#include <iostream>
#include <queue> 
#include <stack> 
#include <map> 
#include <set> 
#include <bitset> 
#include <cstdio> 
#include <algorithm> 
#include <cstring> 
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
#define ll long long
const int mod = 998244353;
const int maxn = 1e5 + 10;
int a[maxn], b[maxn];
int vis[maxn];
int main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        memset(vis, 0, sizeof(vis));
        int n;
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
        for(int i = 1; i <= n; i++) scanf("%d", &b[i]);
        ll ans = 1;
        int flag = 1;
        for(int i = 2; i <= n; i++) {
            if(a[i] != a[i-1] && b[i] != b[i-1]) {
                flag = 0;
                break;
            }
            if(a[i] > a[i-1] || b[i] < b[i-1]) {
                flag = 0;
                break;
            }
            if(a[i] == a[i-1] && b[i] == b[i-1]) {
                ans = ans * (b[i] - a[i] - i + 2) % mod;
            }
        }
        if(flag)
            printf("%lld\n", ans);
        else puts("0");
    }
}

 

转载于:https://www.cnblogs.com/lonewanderer/p/5682586.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值