Ignatius and the Princess III
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 40 Accepted Submission(s) : 30
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
#include<stdio.h>
#include<string.h>
const int N = 125;
#define LL __int64
LL dp[N][N][N],sum[N][N];
int main(){
memset(dp,0,sizeof(dp));
memset(sum,0,sizeof(sum));
for(int i=1;i<=124;i++)
dp[i][1][i]=1;
sum[1][1]=1;
for(int i=2;i<=124;i++)//苹果数
for(int j=2;j<=i;j++){ //盘子数
for(int k=0;k<=i/j;k++){ //最后一个盘放的数量
dp[i][j][k]=0;
for(int tk=k;tk<=(i-k)/(j-1);tk++)//倒数第二个盘放的数量
dp[i][j][k]+=dp[i-k][j-1][tk];
sum[i][j]+=dp[i][j][k];
}
}
int n;
while(scanf("%d",&n)>0)
printf("%I64d\n",sum[n][n]);
}