<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[dddxxy的博客]]></title><description><![CDATA[]]></description><link>https://blog.youkuaiyun.com/dddxxy</link><language>zh-cn</language><generator>https://blog.youkuaiyun.com/</generator><copyright><![CDATA[Copyright &copy; dddxxy]]></copyright><item><title><![CDATA[Python调用webservice服务【suds-py3组件使用】]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/119916649</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/119916649</guid><author>dddxxy</author><pubDate>Wed, 25 Aug 2021 19:14:24 +0800</pubDate><description><![CDATA[先记录一下背景：
工作中一次与其他系统进行接口调用调试时，对方提供了webservice的一套服务文档和调用参数说明。what？webservice？没怎么用过，以为和API形式的调用差不多，但基于尊重，还是先百度了一下，不看不知道，一看吓一跳！

百度百科：
Web Service是一个平台独立的，低耦合的，自包含的、基于可编程的web的应用程序，可使用开放的XML（标准通用标记语言下的一个子集）标准来描述、发布、发现、协调和配置这些应用程序，用于开发分布式的交互操作的应用程序。

案例说明【踩坑步骤】：]]></description><category></category></item><item><title><![CDATA[BASH：给定一个文本文件 file.txt，请只打印这个文件中的第十行。]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/109635889</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/109635889</guid><author>dddxxy</author><pubDate>Thu, 12 Nov 2020 09:32:00 +0800</pubDate><description><![CDATA[给定一个文本文件 file.txt，请只打印这个文件中的第十行。错误答案：正确答案：
刷leecode遇到一道很简单的题，：给定一个文本文件 file.txt，请只打印这个文件中的第十行。然而我一开始做错了~还没找出来原因，所以想记录下
O,这里题目要求是用shell做，我就用了bash。
大家可以先自己写下自己的答案，然后康康是不是也和我一样，做错了呢，哈哈~

下面是：
错误答案：
这是我的答案：head -n 10 file.txt| tail -n 1
这个错误的答案哦~
当实际行数不足10行时，第]]></description><category></category></item><item><title><![CDATA[【Linux企业故障分析：资源角度】CPU]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/109224164</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/109224164</guid><author>dddxxy</author><pubDate>Wed, 11 Nov 2020 10:38:05 +0800</pubDate><description><![CDATA[目录：一：CPU入门：查看系统本身CPU信息：cpu负载的查看方式

一：CPU入门：

Socket     –  物理CPU槽数，一个完整的物理封装
Core        –  物理CPU核数，物理cpu核心单元组
Thread    –  逻辑CPU数量，模拟值
查看系统本身CPU信息：
1.lscpu
2.cat /proc/cpuinfo
3.dmidecode -t processor



对CPU参数有强了解需求的话，可以参考该文章的一些参数
系统本身的CPU信息，通常我们要用到的不多，了]]></description><category></category></item><item><title><![CDATA[【sql入门】基础语句学习]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/108991112</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/108991112</guid><author>dddxxy</author><pubDate>Thu, 15 Oct 2020 12:00:13 +0800</pubDate><description><![CDATA[python操作数据库一：数据库分类1.关系型数据库2.非关系型数据库二：Mysql入门MySQL安装配置sql语句1.创建数据库：2.使用数据库：3.创建表：4.插入语句5.查询语句
一：数据库分类
1.关系型数据库
2.非关系型数据库
关系型数据库如下：

sqlite为嵌入式数据库，excel可以理解为关系型数据库
No SQL（Not Only SQL）：非关系型数据库
非关系型数据库如下：

非关系型数据库主要有：文档型、k-v型、列式数据库（分布式存储）、图形数据库
== 关系型数据库与非关系型]]></description><category></category></item><item><title><![CDATA[【Python】：好好学习天天向上实例]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/105256781</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/105256781</guid><author>dddxxy</author><pubDate>Wed, 01 Apr 2020 22:04:32 +0800</pubDate><description><![CDATA[本篇文章将引入mooc网课《Python语言程序设计》学习时的一个例子：好好学习天天相上。
·假如每天学习1%，一年能学习多少呢?
·假如周内学习1%，周末遗忘1%，一年能学习多少呢？
·假如有两个人，一位每天学习，一位周内学习，周末不学习，不学习会遗忘1%，那么第二位需要每天努力多少才能追赶的上第一位呢？

一：周内每天学习，周末不学习


二：每天都学习：
每天都学习1%会是个很大的数字，所以...]]></description><category></category></item><item><title><![CDATA[【Python】数字类型及操作---一点就通！]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/105254431</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/105254431</guid><author>dddxxy</author><pubDate>Wed, 01 Apr 2020 20:56:30 +0800</pubDate><description><![CDATA[文章目录一:数字类型整数类型浮点数类型复数类型二：数值运算符三：二元增强赋值形式四：数据类型变化五： 数值运算/（数据转型）函数：

本章将着重介绍在python语言中会使用到的一些数字类型
一:数字类型
和数学中的数字一样，python语言也将数字进行了分类：整数、浮点数、复数
整数类型
可正可负，没有取值范围
通常定义为int型


整数有4种进制的表示形式:
十进制：1010，99，-217...]]></description><category></category></item><item><title><![CDATA[【Python】：turtle库绘图]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/105071180</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/105071180</guid><author>dddxxy</author><pubDate>Tue, 24 Mar 2020 22:13:07 +0800</pubDate><description><![CDATA[文章目录代码：turtle库（海龟库）介绍：RGB色彩的部分值通过样例熟悉用法：
本篇博文将通过使用Python语言来介绍海龟函数turtle()的用法
代码：
“#”号后为注释内容，可省略，在注释中补充介绍了一些函数语法。
建议通过研读下列代码即其后备注，理解turtle库的用法。
#绘制蟒蛇

import turtle
#导入绘图库turtle
# 使用from 库 import 函数/* ...]]></description><category></category></item><item><title><![CDATA[【Python】：内置保留字]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/105057969</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/105057969</guid><author>dddxxy</author><pubDate>Mon, 23 Mar 2020 21:19:19 +0800</pubDate><description><![CDATA[在Python语言中，内置33个保留字，可以理解为python语言的基本单词。
在变量命名时，不可与保留字相同
保留字区分大小写，例如AND可以作为变量使用，而and则是保留字，不可作为变量出现。


                      DDDXXY


...]]></description><category></category></item><item><title><![CDATA[【Python】：温度转换实例]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/105057727</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/105057727</guid><author>dddxxy</author><pubDate>Mon, 23 Mar 2020 21:12:51 +0800</pubDate><description><![CDATA[华氏度与摄氏度转换
本文主要通过一段简单代码，介绍在python中实现温度转换的一个样例。
代码来自mooc国家精品课程《Python语言程序设计》，也是我重温python的指导课程。
我在每行代码后都做了备注，方便大家进行理解。
'''
规定输入格式为：数值+C/F  C代表输入为摄氏度，F代表输入为华氏度。
例如：20.5C   20.5c   60F  58.2f

摄氏度与华氏度的换算为：...]]></description><category></category></item><item><title><![CDATA[【Python】学习之同切圆与五角星绘图]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/105036995</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/105036995</guid><author>dddxxy</author><pubDate>Sun, 22 Mar 2020 22:40:24 +0800</pubDate><description><![CDATA[文章目录Python：同切圆·交互式演示:·文件式演示:Python：五角星交互式演示:·文件式演示:
近期因为学习sdn使用ryu控制器的缘故，重拾python，借此机会也想学习更多的python内容。在此记录一些课程所学。课程是mooc上的国家精品课，有值得借鉴的意义，对于我来说学习此课程恰到好处。
环境：Windows下的Python3.8
Python：同切圆
·交互式演示:
1.绘图需要...]]></description><category></category></item><item><title><![CDATA[ubuntu安装RYU过程问题记录]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/104252191</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/104252191</guid><author>dddxxy</author><pubDate>Mon, 10 Feb 2020 18:05:45 +0800</pubDate><description><![CDATA[本篇文章前半部分记录遇到的问题，后半部分（横线以下，是解决办法）
问题一：网络是OK的，可以ping通外网，但是从github上无法获取ryu的资源。获取命令是按照github上所给的。



在网上百度了各种文章，有的说重启网络，有的说将git换位http，有的说是自己内网的问题，有些网站可以访问，有些就是无法访问（我理解为这是在说网络代理的问题）。
做的尝试：
改用http：

重启网络：这里...]]></description><category></category></item><item><title><![CDATA[SDN基础&&应用方案]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/104044009</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/104044009</guid><author>dddxxy</author><pubDate>Sun, 19 Jan 2020 19:06:17 +0800</pubDate><description><![CDATA[SDN基础&amp;&amp;应用方案SDN定义理解SDN的两种应用方案一：从纯软件方面来升级系统到SDN：二：从硬件方面来升级系统到SDN：

SDN定义理解
前言：最近因为一些原因在系统学习SDN，就在这里开始梳理记录。从大趋势上来看，SDN已经有几年的应用时间，很多企业也都推出了自己的SDN方案，SDN是一个较大的体系，更是网络未来的发展方向之一。

一直以来我都比较喜欢查阅百度百科的词条定...]]></description><category></category></item><item><title><![CDATA[ARP协议&ICMP协议]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/100640322</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/100640322</guid><author>dddxxy</author><pubDate>Sun, 08 Sep 2019 23:19:30 +0800</pubDate><description><![CDATA[文章目录ARP（Address Resolution Protocol）：地址解析协议产生原因：功能：在以太网中，arp协议的使用：ARP协议的缺陷：ARP欺骗ICMP（Internet Control Message Protocol）因特网控制报文协议从ICMP的应用来了解它的具体功能：ICMP原理：报文格式：ICMP的报文种类：ICMP的两个主要应用：

ARP（Address Resolu...]]></description><category></category></item><item><title><![CDATA[抓包分析数据帧中IP数据包的一些关键字段【南邮网课例题】]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/100601629</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/100601629</guid><author>dddxxy</author><pubDate>Sat, 07 Sep 2019 17:19:42 +0800</pubDate><description><![CDATA[最近在看网课重新学习网络方面的知识，这里记录一道觉得蛮不错的基础题：
题目如下:

参考IP数据报格式:【需要自行记忆，题目中是没有给出的】

IP数据报格式：


首先理解：
左边的部分表示：数据帧字节的格式【16进制】，即0010表示该行右边第一个字节的编号是第16个字节。0020即表示是第32个字节
目的MAC地址： f0 1f af 67 52 a7
源MAC地址：00 19 e0 38 ...]]></description><category></category></item><item><title><![CDATA[HTTP code（状态码）]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/100291186</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/100291186</guid><author>dddxxy</author><pubDate>Mon, 02 Sep 2019 15:32:46 +0800</pubDate><description><![CDATA[HTTP状态码（英语：HTTP Status Code）是用以表示网页服务器超文本传输协议响应状态的3位数字代码。它由 RFC 2616 规范定义的，并得到 RFC 2518、RFC 2817、RFC 2295、RFC 2774 与 RFC 4918 等规范扩展。所有状态码的第一个数字代表了响应的五种状态之一。所示的消息短语是典型的，但是可以提供任何可读取的替代方案。 除非另有说明，状态码是HTT...]]></description><category></category></item><item><title><![CDATA[牛客网刷题之错题总结【个人错题总览】--9.2日]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/100192076</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/100192076</guid><author>dddxxy</author><pubDate>Mon, 02 Sep 2019 10:31:15 +0800</pubDate><description><![CDATA[1.SQL 语言又称为 ______ 。
A.结构化定义语言
B.结构化控制语言
C.结构化查询语言
D.结构化操纵语言
答案：C（结构化查询语言）
结构化查询语言(Structured Query Language)简称SQL，结构化查询语言是一种数据库查询和程序设计语言，用于存取数据以及查询、更新和管理关系数据库系统；

2.Ethernet 的核心技术是它的随机争用型介质访问控制方法，即（）...]]></description><category></category></item><item><title><![CDATA[NAT：网络地址转换方法]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/100191731</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/100191731</guid><author>dddxxy</author><pubDate>Mon, 02 Sep 2019 09:45:38 +0800</pubDate><description><![CDATA[NAT（Network Address Translation，网络地址转换）
百度百科：nat
NAT（Network Address Translation，网络地址转换）是1994年提出的。当在专用网内部的一些主机本来已经分配到了本地IP地址（即仅在本专用网内使用的专用地址），但现在又想和因特网上的主机通信（并不需要加密）时，可使用NAT方法。
这种方法需要在专用网连接到因特网的路由器上安装...]]></description><category></category></item><item><title><![CDATA[通信：私有地址]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/100189373</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/100189373</guid><author>dddxxy</author><pubDate>Sun, 01 Sep 2019 23:01:04 +0800</pubDate><description><![CDATA[私有地址
TCP/IP协议中，专门保留了三个IP地址区域称为私网地址，或私有地址。
IP地址 分为5类，其中A，B，C三类中各保留了3个区域作为私网地址，也就是局域网用的，私网地址不能在公网上出现，只能用在内部网路中，所有的路由器都不能发送目标地址为私网地址的数据报。
私网地址是：
A类地址：10.0.0.0～10.255.255.255
B类地址：172.16.0.0 ～172.31.255.2...]]></description><category></category></item><item><title><![CDATA[网易面试题：卡特兰数]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/100159789</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/100159789</guid><author>dddxxy</author><pubDate>Fri, 30 Aug 2019 15:54:53 +0800</pubDate><description><![CDATA[题目： 有20个人去看电影，电影票50元。其中只有10个人有50元钱，另外10个人都只有一张面值100元的纸币，电影院没有其他钞票可以找零，问有多少种找零的方法？
视频讲解，卡特兰数问题
题目解析:要想可以零钱找得开，那么在第一个收的必须是50元，要想后续每次都找的开，那么在每一次收钱的时候，收银员已经收过的50元的个数要大于已经收过的100元的个数。
从(0,0)开始记录收银员已经收银的状态，左...]]></description><category></category></item><item><title><![CDATA[zabbix+onealert云告警+微信通知]]></title><link>https://blog.youkuaiyun.com/dddxxy/article/details/99970557</link><guid>https://blog.youkuaiyun.com/dddxxy/article/details/99970557</guid><author>dddxxy</author><pubDate>Thu, 22 Aug 2019 17:53:53 +0800</pubDate><description><![CDATA[【监控+告警】是运维的必备手段之一，通过下面的内容，我将详细讲解zabbix与onealert告警系统的结合使用。]]></description><category></category></item></channel></rss>