Network
文章平均质量分 60
dayancn
这个作者很懒,什么都没留下…
展开
专栏收录文章
- 默认排序
- 最新发布
- 最早发布
- 最多阅读
- 最少阅读
-
iperf使用方法
iperf使用方法转载 2016-02-24 17:31:32 · 25066 阅读 · 0 评论 -
linux内核IP地址转换函数
http://www.cloudbbs.org/forum.php?mod=viewthread&tid=17856IP 地址转换(字符串 -> 数值)#includeiph->saddr = in_aton("1.1.1.1");打印 IP 地址#includeprintk("%d.%d.%d.%d\n", NIPQUAD(iph->saddr));#de转载 2015-01-23 19:49:51 · 7920 阅读 · 0 评论 -
LLMNR协议
LLMNR协议http://en.wikipedia.org/wiki/Link-local_Multicast_Name_ResolutionThe Link Local Multicast Name Resolution (LLMNR) is a protocol based on the Domain Name System (DNS) packet format转载 2015-03-17 16:00:22 · 4058 阅读 · 0 评论 -
[linux]网络报文发送、接收调用链
http://blog.chinaunix.net/uid-20485483-id-82939.html网络报文从应用程序产生,通过网卡发送,在另一端的网卡接收数据并传递给应用程序。这个过程网络报文在内核中调用了一系列的函数。下面把这些函数列举出来,方便我们了解网络报文的流程。发送流程:write |sys_write |sock_sendmsg |i转载 2015-04-23 23:21:36 · 2246 阅读 · 0 评论 -
what is broute
what is brouteA brouter (pronounced BRAU-tuhr or sometimes BEE-rau-tuhr) is a network bridge and a router combined in a single product.A brouter (pronounced BRAU-tuhr or sometimes BEE-rau-tuhr转载 2015-04-17 23:14:29 · 1059 阅读 · 0 评论 -
Linux内核ARP的处理函数分析(arp_rcv, arp_send)
Linux内核ARP的处理函数分析(arp_rcv, arp_send)int arp_rcv(struct sk_buff *skb, struct net_device *dev, struct packet_type *pt) 当系统的网络驱动程序收到一个arp包的时候,调用这个函数处理。简单来说,arp_rev 发回本机器或者它转载 2015-04-26 23:19:02 · 6917 阅读 · 0 评论 -
VLC组播与接收
VLC组播与接收搭建组播服务器第一步:运行程序后选择“媒体--串流”;第二步:通过“添加”选择需要播放的文件(以wmv文件为例),单击“串流”;第三步:流输出有三项需要设置:来源、目标和选项。来源刚才已指定,点击“下一个”;第四步:勾选“在本地显示”,选择“RTP/ MPEG Transport Stream”输出,单击“添加”;第五转载 2014-11-24 16:20:05 · 7311 阅读 · 0 评论 -
IMQ(Intermediate queueing device)
编译IMQ过程IMQ(Intermediate queueing device)中介队列设备通常用于解决两个问题: 简单来说,IMQ可以让你往一个队列规定中放任何东西,例如对刚刚进入网卡的数据包打上标记去进行入口整形等。但由于一些原因,IMQ设备并没有加入Linux的标准核心中,所以,使用前需要先单独编译。一、运行平台关于最新的IMQ patch见这里:Linu转载 2015-05-20 15:32:38 · 2727 阅读 · 0 评论 -
Load-sharing vs Load-balancing
Load-sharing vs Load-balancingJune 3, 2009The terminology load sharing vs. load balancing are commonly misunderstood terms in the networking industry. Most people use the term load-balancing wh转载 2015-05-26 16:35:36 · 2222 阅读 · 0 评论 -
iptables的CONNMARK与MARK
iptables的CONNMARK与MARiptables的CONNMARK与MARK是用于给数据连接和数据包打标记的两个target。一直没搞明白二者的区别。直到昨天花了不少时间解决openwrt下多路合并时工行网银登录问题,才大致弄清这两个target的用法。两者的区别在于,同样是打标记,但CONNMARK是针对连接的,而MARK是针对单一数据包的。这么说大家肯转载 2015-05-22 17:01:18 · 1482 阅读 · 0 评论 -
HFSC Scheduling with Linux
HFSC Scheduling with Linux© 2005 Klaus Rechert, Patrick McHardy © 2006 Martin A. Brown (translation)For complex traffic shaping scenarios, hierarchical algorithms arenecessary. Current versions转载 2015-05-22 09:45:22 · 766 阅读 · 0 评论 -
802.3af与802.3at区别及PSE与PD名词解释
802.3af与802.3at区别及PSE与PD名词解释PoE(Power over Ethernet,以太网供电)是一种局域网技术,可通过双绞线向受电设备提供直流功率,目前已在在企业与工业应用中得到广泛的应用。据统计,2006年,以太网供电交付量为3200万个端口,到2011年,交付量将增长到1.45亿个端口,年增长率将超过30%。IEEE 802.3af:该标准规定了供电设转载 2015-05-26 11:39:08 · 21584 阅读 · 1 评论 -
arp_ignore和arp_announce内核参数
arp_ignore和arp_announce内核参数 arp_announce : INTEGER默认为0对网络接口上本地IP地址发出的ARP回应作出相应级别的限制:确定不同程度的限制,宣布对来自本地源IP地址发出Arp请求的接口0 - (默认) 在任意网络接口上的任何本地地址1 -尽量避免不在该网络接口子网段的本地地址. 当发起ARP请求的源IP地址是被设置应该经由转载 2015-08-25 14:47:01 · 2439 阅读 · 0 评论 -
OpenVas 8 on Ubuntu Server 14.04
OpenVas 8 on Ubuntu Server 14.04This installation is not made for public facing servers, there is no build in security in my setup.Everything is run as root in this example below, including daem转载 2015-07-31 07:02:18 · 1444 阅读 · 0 评论 -
provisioning definition
provisioning definitionIn general, provisioning means "providing" or making something available. The term is used in a variety of contexts in IT. For example, ingrid computing, to provision is t转载 2015-08-26 15:39:50 · 599 阅读 · 0 评论 -
NSLOOKUP
Nslookup – Common Usage ExamplesNSLOOKUP is a basic command line utility for DNS queries, it’s built into Windows and should be a tool you’re familiar with. Here are some real world examples which转载 2015-11-05 19:00:51 · 975 阅读 · 0 评论 -
IVL 和 SVL
http://blog.sina.com.cn/s/blog_3df962a30100syp4.html网上有很多说到关于IVL和SVL的东西,说得很好,但是对于一点基础都没有的人估计不能看得很明白。我这里从交换机收到packet开始讲两种情况交换机的行为。IVL(independentvlan learning)网上大部分资料都说为每个vlan建一个表,看起来好像有很多表,其转载 2015-01-20 22:22:18 · 4256 阅读 · 0 评论 -
使用iperf测试网络性能
使用iperf测试网络性能iperf 是一个 TCP/IP 和 UDP/IP 的性能测量工具,能够提供网络吞吐率信息,以及震动、丢包率、最大段和最大传输单元大小等统计信息;从而能够帮助我们测试网络性能,定位网络瓶颈。iperf是开源的,源代码可以从http://sourceforge.net/projects/iperf/下载。1. iperf能够做什么提转载 2016-04-12 09:40:24 · 6867 阅读 · 0 评论 -
名词解释
SFP: Small Form-factor PluggableTPS-TC: Transport Protocol Specific - Transmission Convergence循环校验码(CRC码):是数据通信领域中最常用的一种差错校验码,其特征是信息字段和校验字段的长度可以任意选定。FEC:Forward Error Correction,前向纠错。是一种数据转载 2013-06-26 15:06:52 · 2259 阅读 · 0 评论 -
TCP选项详解
TCP选项详解窗口扩大因子TCP Window Scale Option (WSopt)1.前言 TCP窗口缩放选项是用来增加TCP接收窗口的大小而超过65536字节。这个TCP选项以及其他的几个选项在RFC1323(处理长肥管道网络,LFN)中定义。 窗口缩放因子对于BDP大于64KB的时候的数据传输的效率非常有用。例如,如果一个T1传输链路,1.5Mbps是通过转载 2016-05-30 11:09:17 · 1359 阅读 · 0 评论 -
TCP socket的accept/connect成功返回可是对端却不辞而别
TCP socket的accept/connect成功返回可是对端却不辞而别在编写TCP程序的时候,对于服务端,accept成功返回的时候,就一定意味着某个客户端已经成功建立了TCP连接吗?对于客户端,connect成功返回就一定意味着自己成功?在编写TCP程序的时候,对于服务端,accept成功返回的时候,就一定意味着某个客户端已经成功建立了TCP连接吗?对于客户端,connec转载 2016-04-22 10:12:46 · 2317 阅读 · 0 评论 -
linux里的backlog详解
linux里的backlog详解转载 2016-04-22 11:30:51 · 682 阅读 · 0 评论 -
修改 Win7 MTU 值
修改 Win7 MTU 值对于 MTU(Maximum Transmission Unit,最大传输单元)的简单说明:网络上传输的并非连续的数据流,而是一个个的数据包,MTU的值限定了这个数据包的最大值。如果电信运营商设定的数据包最大值为1480字节,而你的电脑通过路由器上网,默认是使用1500字节(如果是直连Modem,则会自动采用电信提供的 MTU值),那么你发送的转载 2016-06-01 17:04:34 · 2249 阅读 · 0 评论 -
Linux raw socket
我们平常所用到的网络编程都是在应用层收发数据,每个程序只能收到发给自己的数据,即每个程序只能收到来自该程序绑定的端口的数据。收到的数据往往只包括应用层数据。某些情况下我们需要执行更底层的操作,比如监听所有本机收发的数据、修改报头等。通过原始套接字,我们可以抓取所有发送到本机的IP包(包括IP头和TCP/UDP/ICMP包头),也可以抓取所有本机收到的帧(包括数据链路层协议头)。普通的套接字无法转载 2016-06-30 14:44:57 · 816 阅读 · 0 评论 -
include/linux/if_ppp.h:135: error: expected specifier-qualifier-list before 'aligned_u64'
solution:add the following code in include/linux/if_ppp.h before struct pppol2tp_ioc_stats.#ifdef aligned_u64#undef aligned_u64#endif#define aligned_u64 unsigned long long __attribut原创 2016-07-05 09:45:00 · 2281 阅读 · 0 评论 -
Uplink Port Definition
An uplink port is a special port (i.e., connector) on a network switch orhub that reverses the transmit and receive circuits of anytwisted pair cable connected to it. It is also referred to as an转载 2016-09-24 15:49:21 · 1112 阅读 · 0 评论 -
备忘链接
https://www.kernel.org/doc/htmldocs/networking/index.html转载 2016-10-24 17:22:09 · 348 阅读 · 0 评论 -
Multicast MAC in Source MAC Address Field
http://www.tomshardware.com/forum/20053-42-multicast-source-address-fieldThis is discussed in Radia Perlman's Interconnections (ISBN0-201-56332-0), Chapter 4, and in IEEE 802.1D Annex C.In sho转载 2016-11-30 14:43:10 · 786 阅读 · 0 评论 -
Tonyo
一直从事开发通讯设备这么多年,一直没搞清楚,网络RJ45后面连接的黑色方块是什么。这个方块通常都是Tonyo的,原来就是一个变压器或者是滤波器。可以防雷击,静电等!希望对这个东西有了解的人,可以回复更详细一点。原创 2016-12-02 11:10:56 · 492 阅读 · 0 评论 -
wire speed
wire speedWire speed refers to the rate of data transfer a given telecommunication technology provides at the physical wire level.Wire-speed, an adjective, describes any hardware box or function t转载 2017-05-11 15:09:55 · 547 阅读 · 0 评论 -
什么叫上CPU
什么叫上CPU? 在交机机上,我们经常会说一个包上CPU。那么为什么会有这种说法呢?我个人认为可以这样理解,如果一个网络封包不是发给交换机自己的,那么交换机的交换芯片会直接转发,无须其它软硬件参与。而如果一个网络封包要收到操作系统处理,那么交换芯片收到封包后,会传给操作系统处理。实际上所有的软件包括操作系统都会被编译成相应的CPU架构的指令,而所有的指令都是由CPU运行的原创 2017-05-12 10:15:22 · 1193 阅读 · 0 评论 -
SNMP 协议对应的RFC文件
Protocols: SNMPv1: A Simple Network Management Protocol (RFC 1157), (RFC1157-SNMP)SMMPv2, SNMPv3: RFC 3416 SMI (Structure of Management Information)SMIv1: SMI (RFC 1155,RFC1155-SMI),转载 2018-01-26 16:25:10 · 4454 阅读 · 0 评论 -
ARP代理
ARP代理(Proxy ARP)作者:易隐者 发布于:2012-9-16 9:33 Sunday 分类:网络分析 ARP代理通俗地说,就是由中间设备代替其他主机响应arp请求。下图展现了ARP代理工作的主要过程:ARP代理工作过程示意图ARP代理工作的过程说明1,192.168.0.16/16主机向外发送目的主机为192.168.1.3/24的ARP请求报转载 2014-07-21 12:29:48 · 1733 阅读 · 0 评论 -
IPv6的链路本地(link-local)地址和站点本地(site-local)地址
IPv6的链路本地(link-local)地址和站点本地(site-local)地址目录(?)[-]IPv6大概可以分为四类链路本地Link-Local地址站点本地Site-Local地址IPv6大概可以分为四类1)单播地址(unicast address)2)组播地址(Multicast Address)IPv6转载 2013-12-03 17:14:34 · 7572 阅读 · 0 评论 -
基于DS-lite的IP城域网向IPv6演进过渡方案研究
http://pda.c114.net/166/a790352.html0 前言随着互联网业务的快速发展,互联网号码分配授权委员会(IANA)及亚太互联网络信息中心(APNIC)可分配的IPv4公有地址已于2011年上半年分配完毕,各电信运营商所申请的IPv4公网地址也将陆续耗尽。但随着互联网的进一步发展和普及,尤其是移动互联网、物联网、云计算等各类新应用的迅速发展,IP地址转载 2014-02-04 11:48:30 · 4695 阅读 · 1 评论 -
DHCP Option 82详细讲解
http://www.agou.net/article/study/699.htm option 82是dhcp报文中的中继代理信息选项(relay agent information option)。当dhcp client发送请求报文到dhcp server时,若需要经过dhcp中继,则由dhcp中继将option 82添加到请求报文中。option 82包含很多sub-optio转载 2014-02-21 10:02:23 · 7123 阅读 · 0 评论 -
DHCPv6 简介
DHCPv6 简介32.1 DHCPv6简介随着IPv6网络的发展,基于IPv6网络的应用范围也逐步广泛起来,作为IPv6在设计之初就提出的框架,网络节点的自动配置成为了IPv6网络的一个主要特点。在新的网络框架中,提出了无状态配置和全状态配置的概念。通过无状态自动配置,网络中新加入的节点可以通过路由通告(Router Advertisement)完成所有的配转载 2013-12-05 08:04:08 · 10034 阅读 · 0 评论 -
Tunneling - GRE/L2TP
Tunneling - GRE/L2TPContents1GRE Tunnel1.1Tunnel Configuration1.2Bridge Configuration1.3Considerations2L2TP Tunnel2.1Tunnel Configuration2.2Considerations转载 2014-02-21 16:07:09 · 2270 阅读 · 0 评论 -
DHCPv6技术介绍
DHCPv6技术介绍目 录DHCPv6DHCPv6概述DHCPv6网络构成DHCPv6地址/前缀分配过程交互两个消息的快速分配过程交互四个消息的分配过程地址/前缀租约更新过程DHCPv6无状态配置DHCPv6无状态配置简介DHCPv6无状态配置过程DHCPv6中继工作过程协议规范 DHCPv6DHCPv6概述转载 2014-02-22 10:40:29 · 2299 阅读 · 0 评论 -
PPTP - GRE
PPTP - GREPPTP: Point to Point Tunneling Protocol 点对点隧道协议GRE: Generic Routing Encapsulation 通用路由封装PPTP 的连接过程如下图:PPTP 可以用于在 IP 网络上建立 PPP 会话隧道。在这种配置下,PPTP 隧道和 PPP 会话运行在两个相同的机器上,呼叫方充当转载 2014-02-19 10:43:03 · 1219 阅读 · 0 评论
分享