Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:
h d e l l r lowoThat is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:helloworld!Sample Output:
h ! e d l l lowor参考代码
#include<cstdio>
#include<cstring>
int main(){
char str[81];
scanf("%s",str);
int len=strlen(str);
int lr=(len+2)/3,bot;
bot=lr+(len+2)%3;
for(int i=0;i<lr-1;i++){
printf("%c",str[i]);
for(int j=0;j<bot-2;j++){
printf(" ");
}
printf("%c\n",str[len-1-i]);
}
for(int i=0;i<bot;i++){
printf("%c",str[lr+i-1]);
}
printf("\n");
return 0;
}