A1031. Hello World for U (20)

本文介绍了一种将任意长度(大于等于5)的字符串按U形打印的方法,并提供了一个参考实现代码。该算法确保字符按原始顺序排列,从左垂直线开始向下打印,接着沿底部水平线从左向右打印,最后沿右垂直线向上打印,力求使U形尽可能方正。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1  characters, then left to right along the bottom line with n 2  characters, and finally bottom-up along the vertical line with n 3  characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1  = n 3  = max { k| k <= n 2  for all 3 <= n 2  <= N } with n 1  + n 2  + n 3  - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor
参考代码
#include<cstdio>
#include<cstring>
int main(){
	char str[81];
	scanf("%s",str);
	int len=strlen(str);
	int lr=(len+2)/3,bot;
	bot=lr+(len+2)%3;
	for(int i=0;i<lr-1;i++){
		printf("%c",str[i]);
		for(int j=0;j<bot-2;j++){
			printf(" ");
		}
		printf("%c\n",str[len-1-i]);
	}
	for(int i=0;i<bot;i++){
		printf("%c",str[lr+i-1]);
	}
	printf("\n");
	return 0;
}
	

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值