A1009. Product of Polynomials (25)

本文介绍了一种计算两个多项式相乘的方法,并提供了两种不同的C++实现方案。输入包括两个多项式的系数和指数,输出为乘积多项式的系数和指数形式。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

参考代码1:

#include<cstdio>
const int N=1001;
const int RN=1000001;
double p1[N]={ },p2[N]={ },pro[RN]={ };
int main(){
	int k,count1[N]={ };
	scanf("%d",&k);
	int izero=0;
	for(int j=0;j<k;j++){
		int n;
		double an;
		scanf("%d%lf",&n,&an);
		p1[n]=an;
		count1[izero]=n;
		izero++;
	}
	scanf("%d",&k);
	for(int j=0;j<k;j++){
		int n;
		double an;
		scanf("%d%lf",&n,&an);
		p2[n]=an;
		for(int i=0;i<izero;i++){
			pro[n+count1[i]]+=p2[n]*p1[count1[i]];
		}
	}
	int count=0;
	for(int i=0;i<RN;i++){
		if(pro[i]!=0){
			count++;
		}
	}
	if(count!=0) printf("%d",count);
	else{
		printf("0\n");
		return 0;
	}
	for(int i=1000000;i>-1;i--){
		if(pro[i]!=0){
			printf(" %d %.1f",i,pro[i]);
		}
	}
	printf("\n");
	return 0;
}

参考代码2:

#include<cstdio>
struct {
	int exp;
	double cof;
}poly[1001];
int main(){
	double ans[2001]={ };
	int k1;
	scanf("%d",&k1);
	for(int i=0;i<k1;i++){
		scanf("%d %lf",&poly[i].exp,&poly[i].cof);
	}
	int k2;
	scanf("%d",&k2);
	for(int i=0;i<k2;i++){
		int n;
		double an;
		scanf("%d %lf",&n,&an);
		for(int i=0;i<k1;i++){
			ans[n+poly[i].exp]+=an*poly[i].cof;
		}
	}
		int count=0;
		for(int i=0;i<2001;i++){
			if(ans[i]!=0) count++;
		}
		printf("%d",count);
		for(int i=2000;i>-1;i--){
			if(ans[i]!=0){
				printf(" %d %.1f",i,ans[i]);
			}
		}
		printf("\n");
		return 0;
	}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值