link:http://poj.org/problem?id=2406
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题解:令n为字符串长度,如果n可以被n-next[n]整除,那么这个商就是结果,反之输出1
AC代码:
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
char s[1000010];
int next[1000010];
int kmp()
{
int n=strlen(s);
int i,j;
i=0,j=-1;
next[0]=-1;
while(s[i])
{
if(j==-1||s[i]==s[j])
{
i++,j++;
next[i]=j;
}
else
{
j=next[j];
}
}
int s;
s=n-j;//此时的j就和next[n]相等
if(n%s==0)
return n/s;
else
return 1;
}
int main()
{
while(scanf("%s",s),s[0]!='.')
{
printf("%d\n",kmp());
}
return 0;
}