<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[cs_jiang的专栏]]></title><description><![CDATA[]]></description><link>https://blog.youkuaiyun.com/cs_jiang</link><language>zh-cn</language><generator>https://blog.youkuaiyun.com/</generator><copyright><![CDATA[Copyright &copy; cs_jiang]]></copyright><item><title><![CDATA[kettle配置kafka-consumer到excel]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/104969083</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/104969083</guid><author>cs_jiang</author><pubDate>Thu, 19 Mar 2020 15:56:32 +0800</pubDate><description><![CDATA[大致过程可参考这个哥们的bloghttps://www.cnblogs.com/huhongy/p/7851553.html

简单介绍kafka作为输入,excel作为输出,图示如下



解释kafka参数



① kafka的topic

②与③对应kafka消息的key和message,具体如何模拟发送key,message格式后面介绍,同时对应输出excel的列名

④ zooke...]]></description><category></category></item><item><title><![CDATA[通过2个实例分析java参数传递时按值传递还是按引用传递]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/54409886</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/54409886</guid><author>cs_jiang</author><pubDate>Fri, 13 Jan 2017 16:31:54 +0800</pubDate><description><![CDATA[直接上代码吧

public class TestMap {
	public static void main(String[] args) {
		Map> map = new HashMap>();
		Map innerMap = new HashMap<>();
		innerMap.put("inner1key", "inner1value");
		innerMap.put("in]]></description><category></category></item><item><title><![CDATA[关于java实现的mapreduce程序打包后通过脚本运行出现classnotfound异常]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/54409669</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/54409669</guid><author>cs_jiang</author><pubDate>Fri, 13 Jan 2017 16:17:08 +0800</pubDate><description><![CDATA[eclipse内运行正常  打包通过脚本启动后hadoop报classnotfound等莫名其妙的错误
    解决办法:
      将所有依赖jar都打入到一个jar中即可
      
如图打包时选择第一项即可]]></description><category></category></item><item><title><![CDATA[mapreduce输入源为多hbase数据表 输出目标为多hbase数据表]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/54409414</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/54409414</guid><author>cs_jiang</author><pubDate>Fri, 13 Jan 2017 16:00:24 +0800</pubDate><description><![CDATA[多输入源(多个scan)配置:在job中配置
TableMapReduceUtil.initTableMapperJob(model.getScans(), model.getMapperClass(), model.getOutputKeyClass(),
				model.getOutputValueClass(), job);
其中第一个参数类型 List
多输出源配置:job中配置]]></description><category></category></item><item><title><![CDATA[Hello views]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/7630581</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/7630581</guid><author>cs_jiang</author><pubDate>Mon, 04 Jun 2012 14:28:34 +0800</pubDate><description><![CDATA[1.建立工程----HelloListView
2.创建xml文件 list_item.xml 保存在res/layout/

<TextView xmlns:android="http://schemas.android.com/apk/res/android"
    android:layout_width="fill_parent"
    android:layout_heig]]></description><category></category></item><item><title><![CDATA[Drawable-绘图及效果]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/7629861</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/7629861</guid><author>cs_jiang</author><pubDate>Mon, 04 Jun 2012 13:23:25 +0800</pubDate><description><![CDATA[1.Bitmap File 从文件加载图片
  android支持文件类型有3种（.png,.jpg,.gif）
  java代码中设置方式 R.drowable.filename
  xml中获取方式 @drawable/filename
  例;图片设置背景
<ImageView
    android:layout_height="wrap_content"
    andro]]></description><category></category></item><item><title><![CDATA[利用jacob实现word文档打水印]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6561234</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6561234</guid><author>cs_jiang</author><pubDate>Wed, 22 Jun 2011 15:27:00 +0800</pubDate><description><![CDATA[准备工作：下载jacob相关包及dll文件(dll文件放system32下) 这里不让发附件  需要上面jar包和dll文件的去我的资源里面下载吧  传送门 package test;import com.jacob.activeX.ActiveXComponent;import com.jacob.com.Dispatch;import com.jacob.com]]></description><category></category></item><item><title><![CDATA[子窗口 刷新 父窗口]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6325188</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6325188</guid><author>cs_jiang</author><pubDate>Fri, 15 Apr 2011 11:30:00 +0800</pubDate><description><![CDATA[<br />1.通过window.showModelessDialog("alert.jsp",window);打开<br />   子窗体刷新方法：<br />  var parent=window.dialogArguments;<br />  parent.location.reload();<br />2.通过window.open("alert.jsp"); 打开<br />  子窗体刷新方法：<br />  window.opener.location.reload(); <br />3.通过连]]></description><category></category></item><item><title><![CDATA[sql排序（中文字段按拼音码）]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6321524</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6321524</guid><author>cs_jiang</author><pubDate>Wed, 13 Apr 2011 20:44:00 +0800</pubDate><description><![CDATA[假设字段为state语句为 select * from tablename order by convert(state using gbk) ascs]]></description><category></category></item><item><title><![CDATA[Android深入探究笔记之三 -- Intent (隐式意图和显示意图) ]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6168988</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6168988</guid><author>cs_jiang</author><pubDate>Sat, 29 Jan 2011 16:31:00 +0800</pubDate><description><![CDATA[<br />1. Intent<br />    Android基本的设计理念是鼓励减少组件间的耦合，因此Android提供了Intent (意图) ，<br />    Intent提供了一种通用的消息系统，它允许在你的应用程序与其它的应用程序间传递 Intent 来执行动作和产生事件。<br />    使用 Intent 可以激活 Android 应用的三个核心组件：活动(Activity)、服务(Service)和广播接收器(BroadcastReceiver)。<br /><br />2. 显式意]]></description><category></category></item><item><title><![CDATA[MIME 参考手册 ]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6168819</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6168819</guid><author>cs_jiang</author><pubDate>Sat, 29 Jan 2011 13:20:00 +0800</pubDate><description><![CDATA[<br />  多用途互联网邮件扩展（MIME，Multipurpose Internet Mail Extensions）是一个互联网标准，它扩展了电子邮件标准，使其能够支持非ASCII字符、二进制格式附件等多种格式的邮件消息。这个标准被定义在；RFC 2045，; RFC 2046，; RFC 2047，; RFC 2048，; RFC 2049等RFC中。 由RFC 822转变而来的RFC 2822，规定电子邮件标准并不允许在邮件消息中使用7位ASCII字符集以外的字符。正因如此，一些非英语字符消息和]]></description><category></category></item><item><title><![CDATA[android之pull解析XML]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6168541</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6168541</guid><author>cs_jiang</author><pubDate>Sat, 29 Jan 2011 09:40:00 +0800</pubDate><description><![CDATA[Pull解析和Sax解析不一样的地方有(1)pull读取xml文件后触发相应的事件调用方法返回的是数字(2)pull可以在程序中控制想解析到哪里就可以停止解析xml小明23小李25public static List ReadXmlByPull (InputStream inputStream)throws Exception
	{
		List  personList = null;
		/**
		 * android给我们提供了xml 用来得到xmlpull解析器
		 *]]></description><category></category></item><item><title><![CDATA[java中getResourceAsStream获取路径]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6168534</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6168534</guid><author>cs_jiang</author><pubDate>Sat, 29 Jan 2011 09:23:00 +0800</pubDate><description><![CDATA[<br />   <br />1.Class.getResourceAsStream(String path) <br />  path 不以“/”开头时默认从此类所在的包下取资源，以“/”开头则是从ClassPath根下获取<br />  其只是通过path构造一个绝对路径，最终还是由ClassLoader获取资源<br />2.Class.getClassLoader.getResourceAsStream(String path)<br />  默认是从ClassPath根下获取，path不能以“/”]]></description><category></category></item><item><title><![CDATA[android--apidemo]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6167494</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6167494</guid><author>cs_jiang</author><pubDate>Fri, 28 Jan 2011 08:39:00 +0800</pubDate><description><![CDATA[ANDROID例子程序(ApiDemo)简单分类整理如理解有误，欢迎大家提出 <br />总览： <br />-App(应用) <br />-Content(字体样式) <br />-Graphics(图像) <br />-Media(媒体) <br />-OS(操作系统) <br />-Text(文本显示样式) <br />-Views(视图) <br /><br />-App(应用) <br /><br />--Activity <br />---Animation(教你以怎样的动态效果显示一个新ACT]]></description><category></category></item><item><title><![CDATA[android控件]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6167490</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6167490</guid><author>cs_jiang</author><pubDate>Fri, 28 Jan 2011 08:36:00 +0800</pubDate><description><![CDATA[<br />在Android平台上提供给大家很多丰富的控件，设计一个漂亮的UI在Android平台下可以说是最简单的事情了。<br />  ListView - 列表控件，系统中的通话记录每一条就是使用这个控件编写的。<br />  GridView - 网格控件，我们常见的n宫格设计就是出自这个控件。<br />  TabHost和TabWidget - 这两个组合可以实现标签页的显示效果，类似IE7的一个窗口可以切换多个页面。<br />  ExpandableListView - 这个其实就是Tree]]></description><category></category></item><item><title><![CDATA[Android intent intent-filter ]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6159033</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6159033</guid><author>cs_jiang</author><pubDate>Sat, 22 Jan 2011 20:53:00 +0800</pubDate><description><![CDATA[<br />使用Intent Filter来响应隐式Intent <br />如果一个 Intent 请求在一片数据上执行一个动作， Android 如何知道哪个应用程序（和组件）能用来响应这个请求呢？ Intent Filter就是 用来注册 Activity 、 Service 和 Broadcast Receiver 具有能在某种数据上执行一个动作的能力。 <br /> <br /><br />使用 Intent Filter ，应用程序组件告诉 Android ，它们能为其它程序的组件的动作请求提供]]></description><category></category></item><item><title><![CDATA[android category]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6156284</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6156284</guid><author>cs_jiang</author><pubDate>Fri, 21 Jan 2011 09:36:00 +0800</pubDate><description><![CDATA[<br /><activity android:name="MyActivity"> 
<intent-filter> 
<action android:name="android.intent.action.VIEW"></action> 
<category android:name="android.intent.category.DEFAULT"></category> 
<category android:name="android.intent.category.BROWSABLE"><]]></description><category></category></item><item><title><![CDATA[几种Intent的用法]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6156276</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6156276</guid><author>cs_jiang</author><pubDate>Fri, 21 Jan 2011 09:32:00 +0800</pubDate><description><![CDATA[<br />显示网页:Uri uri = Uri.parse("http://www.google.com"); Intent it   = new Intent(Intent.ACTION_VIEW,uri); startActivity(it); <br />显示地图:Uri uri = Uri.parse("geo:38.899533,-77.036476"); Intent it = new Intent(Intent.Action_VIEW,uri); startActivity(it); <br]]></description><category></category></item><item><title><![CDATA[锁定当前页-css样式]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6151498</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6151498</guid><author>cs_jiang</author><pubDate>Wed, 19 Jan 2011 09:01:00 +0800</pubDate><description><![CDATA[<br />        <mce:style><!--
*{
margin:0;
padding:0;
}

#topCoverDiv{
filter:alpha(opacity=40);-moz-opacity:.4;opacity:0.4;
position:absolute;
width:100%;
height:100%;
background-color:#c0c0c0;
z-index:100;
text-align:center;
}

#dia{
col]]></description><category></category></item><item><title><![CDATA[sqlserver 数据备份与还原]]></title><link>https://blog.youkuaiyun.com/cs_jiang/article/details/6128874</link><guid>https://blog.youkuaiyun.com/cs_jiang/article/details/6128874</guid><author>cs_jiang</author><pubDate>Tue, 11 Jan 2011 13:33:00 +0800</pubDate><description><![CDATA[<br />数据备份命令BACKUP<br />BACKUP命令用来完成数据的备份<br />语法：  BACKUP DATABASE {database_name}<br />[ to < restore_device >]<br />参数说明：<br />database_name：要恢复的数据库名称。需要注意的是，这个数据库要保证在恢复时是关闭的，否则，将会出错。<br />restore_device：要恢复的数据库备份路径。<br />backup database test to disk =']]></description><category></category></item></channel></rss>