http状态码

卫星载荷应用方案 本文将从技术和应用层面探讨卫星载荷的应用方案,分析各个领域的特点和挑战,以期为卫星载荷的应用提供一定的指导和参考。卫星载荷应用方案涵盖了通信、地球观测、气象预报、导航定位等诸多领域在每一个领域中,都存在着不同的技术挑战和应用需求。随着技术的进步和需求的变化,卫星载荷应用方案将不断发展和完善,为人类社会的进步和发展做出更大的贡献。用户可以通过接收多颗卫星的信号,计算自身的位置和速度信息。在覆盖扩展方面,可以采用多星座、MEO、GEO 等不同轨道高度的卫星布局,结合卫星的特点和应用需求,实现覆盖范围的扩展。 阅读详情

​ 在项目实际开发中,前端页面调用后台接口,渲染数据到页面是非常常见的场景,。调用后台接口,从服务器获取数据的时候,可能会出现很多情况,比如404 not found,了解这些http状态码可以帮助我们排查问题。

  1. 分类

    状态码响应类型原因短语
    1xx信息性状态码服务器正在处理请求
    2xx成功状态码请求已正常处理完毕
    3xx重定向状态码需要进行额外操作以完成请求
    4xx客户端错误状态码客户端原因导致服务器无法处理请求
    5xx服务器错误状态码服务器原因导致处理请求出错
  2. 常见状态码

    • 1xx
      • 100 继续,客户端应继续请求
      • 101 切换协议,服务端根据客户端请求切换协议,只能切换到更高级的协议
    • 2xx
      • 200 请求成功,一般用于GET和POST请求
      • 201 成功请求,并创建了新资源
      • 202 已接收请求,但未处理完成
      • 203 请求成功,但返回的meta信息不在原始服务器,而是一个副本
      • 204 服务器处理成功,但未返回内容
      • 205 服务器处理成功,用户终端应重置文档视图
      • 206 服务器成功处理了部分请求
    • 3xx
      • 301 永久移动
      • 302 临时移动
      • 303 查看其它地址,使用GET和POST请求查看
      • 304 未修改(浏览器缓存)
      • 305 使用代理,所请求的资源必须通过代理访问
      • 307 临时重定向,使用GET请求重定向
    • 4xx
      • 400 客户端请求的语法错误,服务器无法理解
      • 401 请求要求用户的身份认证
      • 403 服务器理解客户端的请求,但是拒绝执行此请求
      • 404 服务端无法根据客户端的请求找到资源
    • 5xx
      • 500 服务器内部错误,无法完成请求
      • 501 服务器不支持请求的功能,无法完成请求
      • 502 作为网关或代理工作的服务器尝试执行请求时,从远程服务器接收到一个无效的响应
      • 503 由于超载和系统维护,服务器暂时的无法处理客户端的请求
      • 504 充当网关或代理的服务器,未及时从远端服务器获取请求
      • 505 服务器不支持请求的HTTP协议的版本,无法完成请求
    1. 常问问题

      • 301和302的区别

        301为永久重定向,如果用户把该资源对象的URI保存为书签的话,书签中的网址会被更新

      • 浏览器缓存机制(HTTP缓存机制)

        浏览器每次发送请求之后,都会在浏览器缓存中查看该请求的结果和缓存标识;浏览器每次拿到返回的请求结果之后,都会将该结果和缓存标识存入浏览器缓存中。

        • 强制缓存

          • 当不存在请求结果和缓存标志的时候,向服务器发送请求,请求资源

          • 当存在请求结果和缓存标识,但是结果失效,则协商缓存

          • 当存在请求结果和缓存标识,且结果未失效,直接返回该结果

            浏览器控制强缓存的字段分别是Expires(http/1.0)和Cache-Control(http/1.1),Cache-Control优先级高于Expires,http/1.1中默认使用Cache-Control,因为Expires通过到期时间判断的判断机制,可能因为市区等原因导致偏差,所以http/1.1采用Cache-Control来控制强制缓存。

          Cache-Control取值情况如下:

          public 所有内容都被缓存(客户端和代理服务器)

          private 所有内容只有客户端缓存(默认取值)

          no-cache 协商缓存

          no-store 不缓存

          max-age=xxx 缓存内容在xxx秒后失效

        • 协商缓存

          缓存结果失效后,浏览器携带缓存标志向服务器发起请求,由服务器根据缓存标识判断是否使用缓存

          • 协商缓存失效

            返回304,该资源无法更新

          • 协商缓存成功

            返回200和请求结果

          浏览器控制协商缓存的字段分别为Last-Modified/If-Modified-Since(http/1.0)、Etag/If-None-Match(http/1.1),其中Etag/ If-None-Match比Last-Modified/ If-Modified-Since优先级高

          Last-Modified 资源文件在服务器最后被修改的时间

          If-Modified-Since 上次请求返回的Last-Modified值,如果Last-Modified大于该值,则返回200和结果,否则返回304,无法更新资源,使用缓存文件

          Etag 资源文件唯一标识(由服务器生成)

          If-None-Match 上一次请求返回的Etag 值,如果Etag不等于该值,则返回200和结果,否则返回304,无法更新资源,使用缓存文件

      • http1.0和http1.1的区别

        • 浏览器缓存处理,http1.0通过Last-Modified/If-Modified-Since和Expires等字段控制浏览器缓存,http1.1通过Etag/ If-None-Match和Cache-Control等字段控制浏览器缓存。
        • 带宽优化及网络连接的使用,http1.0存在一些带宽浪费的情况,例如客户端只需要某个对象的额一部分,而服务器却把整个资源送过来,并且不支持断点续存功能;http1.1则在请求头中引入了range头域,允许请求资源的某个部分,则返回码是206,这样方便了开发者自由选择以便于利用带宽和连接。
        • 错误通知管理,在http1.1中新增了24个错误状态码,如409,表示请求的资源与资源的当前状态发生冲突,410,表示服务器上的某个资源被永久删除。
        • host头处理,http1.0认为每台服务器都绑定一个唯一的IP地址,因此请求消息中的URL并没有传递主机名,随着虚拟技术的发展,一台物理服务器可以存在多个虚拟主机,并且共享一个IP地址。http1.1的请求消息和响应消息都应支持host头域,请求消息中如果没有host头域,会报400错误。
        • 长连接,http1.1支持长连接和请求的流水线处理,在一个TCP连接上可以传送多个HTTP请求和响应,减少了建立和关闭连接的消耗和延迟,在http1.1中默认开启Connection:keep-alive,一定程度上弥补了http1.0每次请求都要创建连接的缺点。
      • http1.x和http2.0的区别

        • 新的二进制格式

          http1.x的解析是基于文本的,基于文本的格式解析存在天然缺陷,文本的表现形式有多样性,要做到健壮性考虑的场景必然很多;二进制则不同,只认0和1的组合,http2.0采用二进制格式比较方便和健壮。

        • 多路复用

          即连接共享,每一个request都是用作连接共享机制的,一个request对应一个id,这样一个连接上可以有多个request,每个连接的request可以随机的混杂在一起,接收方可以根据request的id将request归属到各自不同的服务端请求里。

        • header压缩

          http1.x的header带有大量信息,而且每次都要重复发送,http2.0使用encoder来减少要传输的header的大小,通讯双方各自cache一份header fields表,既避免了重复header的传输,又减少了需要传输的大小。

        • 服务端推送

          采用了SPDY的网页,例如我的网页有一个sytle.css的请求,在客户端收到sytle.css数据的同时,服务端会将sytle.js的文件推送给客户端,当客户端再次尝试获取sytle.js时就可以直接从缓存中获取到,不用再发请求了。

          SPDY位于HTTP之下,TCP和SSL之上,这样可以轻松兼容老版本的HTTP协议(将HTTP1.x的内容封装成一种新的frame格式),同时可以使用已有的SSL功能。

      • http和https的区别和联系

        • http协议运行在TCP之上,所有的传输都是明文,https运行在SSL/TLS之上,SSL/TLS运行在TCP之上,所有传输的内容都是经过加密的。
        • http和https使用的是完全不同的连接方式,用的端口也不一样,前者80,后者443。
        • https可以有效的防止运营商劫持,解决了防劫持的一个大问题。
        • https协议需要CA申请证书,一般免费证书很少,需要付费。
abaqus wcm插件下载_Abaqus随机短纤维增强复合材料建模插件 文末附Abaqus随机短纤维增强复合材料建模插件下载链接前言短纤维增强复合材料相对于长纤维增强复合材料来说更容易制备,且短纤维的填充性能略有改善,可制造复杂产品,广泛应用于车辆、航空航天、建筑等行业,对短纤维增强复合材料进行细观力学分析,可对其宏观力学性能进行预测、分析破坏机理等。接下来对随机短纤维增强复合材料建模插件进行介绍。NO.1 【算法简介】难点一:此插件核心在于判断生成的纤维是... 阅读详情

相关推荐

别再手动画柜子了!用EPLAN导入STEP模型,5分钟搞定一个标准机柜

本文详细介绍了如何利用EPLAN Pro Panel的3D布局功能,快速将STEP模型转化为智能机柜宏,大幅提升电气工程设计效率。通过实战步骤解析,包括模型导入、智能解析、安装面定义及拼柜技巧,帮助工程师5分钟内完成标准机柜设计,避免传统手动建模的尺寸偏差问题。

weixin_26875109的博客 433

http状态码大全(100 - 599状态码 全面讲解)

HTTP状态码(HTTP Status Code)是用以表示网页服务器HTTP响应状态的3位数字代码。它由 RFC2616 规范定义的 ,并得到RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。

weixin_63149034的博客 5万+

RK3568 NFS rootfs配置与调试实战指南(已验证)

本文提供了在RK3568开发板上配置NFS rootfs的完整实战指南。通过详细步骤讲解如何配置uboot的bootargs参数、编译支持NFS的内核,并在PC端搭建TFTP与NFS服务器,最终实现从网络挂载根文件系统,从而极大提升驱动调试和应用程序开发的迭代效率。

weixin_29175469的博客 281

HTTP | 常用的 14 个 HTTP 状态码

Hi,大家好,我是半亩花海。本文主要了解常用的 14 个 HTTP 状态码。当浏览者访问一个网页时,浏览者的浏览器会向网页所在服务器发出请求。当浏览器接收并显示网页前,此网页所在的服务器会返回一个包含 HTTP 状态码的信息头(server header)用以响应浏览器的请求。

沉思默想,深度学习,半亩星河半亩月,半亩花海半亩云。 4万+

西门子Industrial Copilot实战:5个工业场景下的AI效率提升案例

本文通过五个工业场景实战案例,深入解析西门子Industrial Copilot如何将工业智能转化为实际生产力。从自动化配置、预测性维护到能源优化与人机交互,这位AI助手显著缩短工程周期、提升设备可用率并降低运营成本,展示了其在工业领域系统化、工程化的落地价值。

3c4x5z6v7b的博客 925

【UE4】PMC程序化生成戈德堡多面体详解(六边形星球)

游戏实机录屏 【魔方超新星】30天独立开发PCG Minigame《盖亚计划》作品展示,尚有不足,大佬轻喷 目录 游戏实机录屏 一、简介 二、设计思路 2.1 Disco Ball 2.2 Fibonacci Sphere 2.3 Goldberg Polyhedron 2.3.1 细分+对偶(最终方案) 2.3.2 对偶+截角(更优) 三、参考文献 一、简介 在制作Minigame初期,游戏风格想模仿《文明6》与《Polygonal Planet Proje...

ColorGalaxy 5928

HTTP常见状态码(200、201、304、400、404、500)等错误

常见的状态码 200(成功) - 服务器成功返回网页 201 (已创建) - 请求成功并且服务器创建了新的资源。 304 (未修改) - 自从上次请求后,请求的网页未修改过。服务器返回此响应时,不会返回网页内容。 400 (错误请求) - 服务器不理解请求的语法。 404(未找到) - 请求的网页不存在 500 (服务器内部错误) - 服务器遇到错误,无法完成请求。 503 (服务不可用)- 服务器目前无法使用(由于超载或停机维护)。通常,这只是暂时状态。 HTTP状态码100-500详细介绍

Shivy_的博客 5万+

LabVIEW调用.so文件的方法

LabVIEW调用.so文件的方法

m0_37878912的博客 3023

HTTP状态码汇总(常见)

HTTP状态码是服务器返回给客户端的,其核心作用是web服务器来告诉客户端,当前网页发生的什么事,或者说当前web服务器的响应状态。所以HTTP状态码常用来判断和分析当前web服务器的运行状况。

Z_CH8648的博客 3万+

麒麟操作系统提示“默认密钥环已上锁”的解决办法

麒麟操作系统提示“默认密钥环已上锁”的解决办法

太极淘的博客 1万+

uni-app开发-第6篇:uni-app 样式与主题

在 uni-app 开发中,样式与主题的管理是关键部分。样式分为全局样式和局部样式,全局样式在 App.vue 中定义,适用于整个应用,而局部样式在单个 .vue 文件中定义,仅对当前页面生效。局部样式优先级高于全局样式,内联样式优先级最高。样式属性如 font-family 和 color 可被子元素继承。要覆盖全局样式,可在局部样式中重新定义相同规则。主题切换通过 CSS 变量和类名实现,动态切换主题可通过修改元素的类名来完成。例如,定义浅色和深色主题,并通过按钮点击切换主题样式。这些方法帮助开发者灵活

无 368

http常见状态码有哪些?

http常见状态码有哪些? 一、2开头的状态码 2xx(成功)表示成功处理了请求的状态码 200(成功)服务器已成功处理了请求。 二、3开头的状态码 3xx(重定向)表示要完成请求,需要进一步操作。通常这些状态代码用来重定向。 304(未修改)自从上次请求后,请求网页未修改过。服务器返回此响应时,不会返回网页内容 三、4开头的状态码 4xx(请求错误)这些状态码表示请求可能出错,妨碍了服务器的处理 400(错误请求)服务器不理解请求的语法 403(禁止)服务器拒绝请求 404(未找到)服务器找不到

nbsl_的博客 4万+

VB摄像头监控

该VB模块可对摄像头捕获的画面进行录像等,可在创建的窗口进行控制

HTTP状态码401,以及其他常见HTTP状态码

背景 调试小程序打开网盘,报错 这个错误是未经授权 状态码大致含义 1开头 主要是信息提示。 2开头 主要是请求成功。 3开头 主要是重定向。 4开头 主要是请求错误。 5、6开头 主要是服务器错误。 常见的http状态码 1XX系列: 指定客户端应相应的某些动作,代表请求已被接受,需要继续处理。由于 HTTP/...

A_Captain 9476

Camera2Demo

在Camera2 的基础上进行封装,使得Camera2一堆初始化逻辑与Activity分离,降低耦合度,完成预览拍照并保存的操作

Devexpress16.2.6破解工具

Devexpress16.2.6破解工具Devexpress16.2.6破解工具Devexpress16.2.6破解工具Devexpress16.2.6破解工具

HTTP状态码

2018年7月10日10:04:54 根据HTTP返回状态码,来判断api状态 以下是中英文HTTP返回状态码的对照信息。 1、信息 - 100 Continue - 101 Switching Protocols - 102 Processing 2、成功 - 200 OK - 201 Created - 202 Accepted - 203 ...

xiaozi_001的博客 2万+

NTscan扫描工具

ntscan是一个扫描器,可以扫描没有密码和弱密码的共享,先到配置文件中填写猜测的用户名和密码,扫描过程中右侧出现的是扫描日志。

405状态码_HTTP状态码

状态码状态码是来告诉客户端,发生了什么事情。状态码为客户端提供了一种理解事务处理结果的便捷方式。状态码位于响应的起始行中 比如,在行 HTTP/1.0 200 OK 中,状态码就是200客户端向一个 HTTP 服务器发送请求报文时,会遇到很多意想不到的情况,请求不一定能够成功完成。服务器可能会告诉你无法找到所请求的资源,你没有访问资源的权限,或者资源被移到了其他地方状态码是在每条响应报文的起始行中...

weixin_39989222的博客 4425

HTTP状态码总结

HTTP状态码(HTTP Status Code)是用以表示网页服务器HTTP响应状态的3位数字代码。有些 App 端接口与 HTML 接口用的是同一个,所以做移动端开发也有必要了解一下HTTP状态码。 我们在开发中常接触的HTTP状态码可能就那么几个,比如200、302、404、500等。那除了这些常见的还有那些呢?分别又表示什么意思? 先来大致总结一下: 状态码大致含义 1开头 ...

小胡的博客 576

HTTP方法以及HTTP状态码

服务器目前从不同位置的网页响应请求,但请求者应继续使用原有位置来响应以后的请求。服务器目前从不同位置的网页响应请求,但请求者应继续使用原有位置来响应以后的请求。请求者应当对不同的位置使用单独的 GET 请求来检索响应时,服务器返回此代码。服务器无法处理请求,因为请求实体过大,超出服务器的处理能力。服务器作为网关或代理,但是没有及时从上游服务器收到请求。如果页面无法提供请求的范围,则服务器会返回此状态码。请求的 URI(通常为网址)过长,服务器无法处理。如果请求的资源已永久删除,服务器就会返回此响应。

2201_75883040的博客 688

什么是HTTP状态码?HTTP状态码有什么用?

转自:微点阅读https://www.weidianyuedu.com Http状态码是什么? 什么是HTTP状态码? HTTP状态码:这是服务器和客户端之间交流信息的语言。 比如: 当客户端向服务器请求一个死链接时,服务器会返回“404”的信息。 “404”就是一个HTTP状态码,这个代码告诉客户端:“你请求的链接,我这边没有”。 再举个例子,“200”这个HTTP状态码代表的是,“你的请求,已经成功发送”。 如果客户端向服务器发送一个链接,服务器返回“200”。那么就说明,服务器..

ysds20211402的博客 466

【HTTP】状态码

当浏览者访问一个网页时,浏览者的浏览器会向网页所在服务器发出请求。当浏览器接收并显示网页前,此网页所在的服务器会返回一个包含HTTP状态码的信息头(server header)用以响应浏览器的请求 HTTP状态码的英文为HTTP Status Code。 HTTP状态码由三个十进制数字组成,第一个十进制数字定义了状态码的类型,后两个数字没有分类的作用。 HTTP状态码共分为5种类型:...

quchen528的博客 557

HTTP 状态码

HTTP 状态码 代码 消息 描述 100 Continue 只有请求的一部分已经被服务器接收,但只要它没有被拒绝,客户端应继续该请求 101 Switching Protocols 服务器切换协议 200 OK 请求成功 201 Created 该请求是完整的,并创建一个新的资源 202 Accepted 该请求被接受处理,但是该处理是不完整的 203 Non-authoritative Information 204 No Content 205 Rese

Lv Zejiang 401

HTTP协议5-HTTP状态码

HTTP状态码 当浏览者访问一个网页时,浏览者的浏览器会向网页所在服务器发出请求。当浏览器接收并显示网页前,此网页所在的服务器会返回一个包含HTTP状态码的信息头(server header)用以响应浏览器的请求。 HTTP状态码的英文为HTTP Status Code。 下面是常见的HTTP状态码: 200 - 请求成功 301 - 资源(网页等)被永久转移到其它U

一夜长风的专栏 2571
上一篇: JavaScript创建对象的7种方式
下一篇: urlArgs解决Require.js浏览器缓存问题
codezha
博客等级 码龄10年 28粉丝 98原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

个

红包个数最小为10个

元

红包金额最低5元

当前余额3.43元 前往充值 >
需支付:10.00元
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值