1017 Queueing at Bank (25 point(s))

本文介绍了一种使用优先队列模拟银行客户排队的算法,通过两个优先队列分别模拟顾客和窗口,实现对平均等待时间的精确计算。文章详细解释了算法的实现细节,包括输入输出规格、关键数据结构定义及操作流程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1017 Queueing at Bank (25 point(s))

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

思路:

用两个优先队列,分别对顾客队列和窗口进行模拟

注意点:

(1)此处需要的是最小堆,注意使用的STL方式和'<'的重载;

(2)>>不可以重载字符串const char[2],使用getchar();

(3)窗口的结构体表示这个窗口下次开放时间。因此依次从优先队列中取出每一个顾客,如果顾客到达的时间早于窗口开放时间 ,则说明顾客需要等待,窗口下次开放时间是在此基础时间再加上顾客服务所需时间,和顾客到达时间的差值是等待时间;否则说明顾客一到就可以得到服务,窗口下次开放时间是顾客到达时间再加上顾客服务所需时间。窗口服务完成后,需要再将窗口加入到队列中。

(4)值得再复习!

//排队事件的模拟 
#include<iostream>
#include<iomanip>
#include<queue>
#include<map>
using namespace std;
struct Window{//记录窗口下一次开放时间 
	int h,m,s;
	bool operator < (const Window &w)const{//按照hh:mm:ss排序 
		if(h!=w.h) return h>w.h;
		if(m!=w.m) return m>w.m;
		return s>w.s;
	}
}; 
struct Customer{
	int hh,mm,ss,time;
	bool operator < (const Customer &c)const{
		if(hh!=c.hh) return hh>c.hh;
		if(mm!=c.mm) return mm>c.mm;
		return ss>c.ss;
	}
};
priority_queue<Window> win;
priority_queue<Customer> cus;
int main(void){
	int N,K;//N customers K windows
	cin>>N>>K;
	Customer c;
	for(int i=0;i<N;i++){
		cin>>c.hh;getchar();
		cin>>c.mm;getchar();
		cin>>c.ss>>c.time;
		cus.push(c);
	}
	Window w;
	for(int i=0;i<K;i++){
		w.s=w.m=0;w.h=8;
		win.push(w);
	} 
	int totalCus=0;double totalTime=0;
	while(!cus.empty()){
		c = cus.top();
		cus.pop();
		if(c.hh>=17&&(c.mm>0||c.ss>0)) break;
		totalCus++;
		
		w = win.top();
		win.pop();
		if(c.hh<w.h||(c.hh==w.h&&c.mm<w.m)||(c.hh==w.h&&c.mm==w.m&&c.ss<w.s)){
			//如果顾客到达的时间早于窗口开放时间 
			totalTime += (w.h-c.hh)*60.0+(w.m-c.mm)+(w.s-c.ss)/60.0;
			w.m = w.m+c.time;
			w.h += w.m/60;
			w.m %= 60;
		}
		else{//如果顾客到达的时间晚于窗口开放时间,即实际上窗口在等待 
			w.s = c.ss;
			w.m = c.mm + c.time;
			w.h += w.m/60;
			w.m %=60; 
		}
		win.push(w);
		
	}
	//cout<<totalTime<<" "<<totalCus<<endl; 
	printf("%.1f",totalTime/totalCus); 
	return 0;
}

参考链接:

https://blog.youkuaiyun.com/sunbaigui/article/details/8657074

https://blog.youkuaiyun.com/liaotl10/article/details/57594612

https://blog.youkuaiyun.com/wsxyh1071652438/article/details/82469835

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值