1132 Cut Integer (20 point(s))

探讨了将一个整数切割成两个较小整数,并判断原整数是否能被这两个新整数的乘积整除的问题。输入包含多个测试用例,每个用例给出一个待测试的整数。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1132 Cut Integer (20 point(s))

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

字符串处理、数学。

注意点:除数不能为0,否则程序错误。

#include<iostream>
#include<cstring>
using namespace std;
int main(void){
	int N;string s;cin>>N;
	while(N--){
		cin>>s;
		while(s[0]=='0') s.erase(s.begin());
		int a = stoi(s.substr(0,s.length()/2));
		int b = stoi(s.substr(s.length()/2));
		int c = stoi(s);
		if(a==0||b==0||c%(a*b)!=0) puts("No");
		else puts("Yes");
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值