1153 Decode Registration Card of PAT (25 point(s))
A registration card number of PAT consists of 4 parts:
- the 1st letter represents the test level, namely,
T
for the top level,A
for advance andB
for basic; - the 2nd - 4th digits are the test site number, ranged from 101 to 999;
- the 5th - 10th digits give the test date, in the form of
yymmdd
; - finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤104) and M (≤100), the numbers of cards and the queries, respectively.
Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.
After the info of testees, there are M lines, each gives a query in the format Type Term
, where
Type
being 1 means to output all the testees on a given level, in non-increasing order of their scores. The correspondingTerm
will be the letter which specifies the level;Type
being 2 means to output the total number of testees together with their total scores in a given site. The correspondingTerm
will then be the site number;Type
being 3 means to output the total number of testees of every site for a given test date. The correspondingTerm
will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input
, where #
is the index of the query case, starting from 1; and input
is a copy of the corresponding input query. Then output as requested:
- for a type 1 query, the output format is the same as in input, that is,
CardNumber Score
. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed); - for a type 2 query, output in the format
Nt Ns
whereNt
is the total number of testees andNs
is their total score; - for a type 3 query, output in the format
Site Nt
whereSite
is the site number andNt
is the total number of testees atSite
. The output must be in non-increasing order ofNt
's, or in increasing order of site numbers if there is a tie ofNt
.
If the result of a query is empty, simply print NA
.
Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
排序题。
1. 尽量使用printf和scanf,否则可能超时;
2. map<key,value>结构方便用来遍历计数,但是如果要基于key和value再排序,则需要遍历map,将它pair<key,value>存储成线性结构(如vector)再重载运算符输出。
map<string,int> mp;
vector<pair<string,int> > v = vector(mp.begin(),mp.end());
bool cmp(pair<string,int> p1,pair<string,int> p2){ }
3. 从字符串中读取信息可以用sscanf;
4. 对于命令1,可以在一开始就排好序,在遇到时顺序遍历即可。并且不会影响命令2和3。
Tips:
如果想要在Dev-Cpp里面使用C++11特性的函数,比如刷算法中常用的stoi、to_string、unordered_map、unordered_set、auto这些,需要在设置里面工具-编译选项-编译器-编译时加入“-std=c++11”
原文链接:https://blog.youkuaiyun.com/liuchuo/article/details/82669248
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>
#include<unordered_map>
using namespace std;
const int MAX = 1e4+7;
int N,M;
struct card{
string cardNumber;
string level;int site,date,number;int score;
};
bool cmp(card a,card b){
if(a.score!=b.score) return a.score>b.score;
return a.cardNumber<b.cardNumber;
}
bool cmp2(pair<int,int> p1,pair<int,int> p2) {
if(p1.second!=p2.second) return p1.second>p2.second;
else return p1.first<p2.first;
}
card c[MAX];
int main(void){
cin>>N>>M;
for(int i=0;i<N;i++){
cin>>c[i].cardNumber>>c[i].score;
c[i].level = c[i].cardNumber.substr(0,1);
c[i].site = stoi(c[i].cardNumber.substr(1,3));
c[i].date = stoi(c[i].cardNumber.substr(4,6));
c[i].number = stoi(c[i].cardNumber.substr(10,3));
}
int type;string s;
sort(c,c+N,cmp);
for(int i=1;i<=M;i++){
cin>>type>>s;
cout<<"Case "<<i<<": "<<type<<" "<<s<<endl;
if(1==type){
bool flag = false;
for(int i=0;i<N;i++){
if(s==c[i].level){
printf("%s %d\n",c[i].cardNumber.c_str(),c[i].score);
flag = true;
}
}
if(!flag) puts("NA");
}
else if(2==type){
int nt=0,ns=0;int key = stoi(s);
for(int i=0;i<N;i++){
if(c[i].site==key){
nt++;
ns+=c[i].score;
}
}
if(nt>0) cout<<nt<<" "<<ns<<endl;
else puts("NA");
}
else if(3==type){
unordered_map<int,int> mp;int key = stoi(s);
for(int i=0;i<N;i++){
if(key== c[i].date){
mp[c[i].site]++;
}
}
if(mp.size()==0) puts("NA");
else{
vector<pair<int,int> >vec(mp.begin(),mp.end());
sort(vec.begin(),vec.end(),cmp2);
for(int i=0;i<vec.size();i++){
printf("%03d %d\n",vec[i].first,vec[i].second);
}
}
}
}
return 0;
}