1039 Course List for Student (25 point(s))

1039 Course List for Student (25 point(s))

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

模拟题。关键点:

1. 读入数据的时候,如果出现不存在姓名,要插入;

2. 查询中可能出现没有出现出现过的名字。

下面代码可能因评判机器的问题,存在玄学TLE的情况。本题的限制时间600ms,而该代码通过时间可能卡在包含该时间的某个区间内。

#include<iostream>
#include<map>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int MAX = 400007; 
map<string,int> mp;
string names[MAX];
vector<int> courses[MAX];
int main(void){
	int N,K,idx,num;
	int cnt = 0;
	string s;
	cin>>N>>K;//学生数、课程数 
	while(K--){
		cin>>idx>>num;
		for(int i=0;i<num;i++){
			cin>>s;int cur;
			if(mp.find(s)!=mp.end()){
				cur = mp[s];
			}
			else{
				mp.insert({s,cnt});
				names[cnt]=s;
				cur = cnt;
				cnt++;
			}
			courses[cur].push_back(idx);
		}
	}
	while(N){
		cin>>s;
		if(mp.find(s)!=mp.end()){
			int stu = mp[s];
			sort(courses[stu].begin(),courses[stu].end());
			int size = courses[stu].size();
			cout<<names[stu]<<" "<<size;
			for(int i=0;i<size;i++){
				cout<<" "<<courses[stu][i];
			}
			cout<<endl;
		} 
		else{
			cout<<s<<" "<<"0"<<endl;
		}
		N--;
	}
	return 0;
} 

 a. 可以AC的时候:

b. case#5出现TLE(23分)

改进:姓名散列

#include<bits/stdc++.h>
using namespace std;
vector<vector<int> >hashTable((int)1e6);//存储相应编号所指代的学生选的课,散列数组的大小尽量要开大一点
int strhash(const string&s){
    int k=0;
    for(int i=0;i<3;++i)
        k=k*26+s[i]-'A';
    k=k*26+s[3]-'0';
    return k;
}
int main(){
    int N,K;
    string name;
    scanf("%d%d",&N,&K);
    for(int i=1;i<=K;++i){
        int course,num;
        scanf("%d%d",&course,&num);
        while(num--){
            cin>>name;
            hashTable[strhash(name)].push_back(course);//让该整数下的vector存储选的课
        }
    }
    while(N--){
        cin>>name;
        int k=strhash(name);//将名字散列为一个整数
        printf("%s %d",name.c_str(),hashTable[k].size());//按要求输出
        sort(hashTable[k].begin(),hashTable[k].end());
        for(int i=0;i<hashTable[k].size();++i)
            printf(" %d",hashTable[k][i]);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值