1050 String Subtraction (20 point(s))
Given two strings S1 and S2, S=S1−S2 is defined to be the remaining string after taking all the characters in S2from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast.
Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
Output Specification:
For each test case, print S1−S2 in one line.
Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
考点:字符串处理、哈希表。
ASCⅡ共有128个(0~127),使用哈希表标记其是否属于s2的字符。如果标记,在s1中不输出,否则输出。常规方法会出现TLE。
#include<iostream>
#include<string>
using namespace std;
const int LEN = 128;
bool mark[LEN]={false};
int main(void){
string s1,s2;
getline(cin,s1);
getline(cin,s2);
for(int i=0;i<s2.length();i++){
mark[s2[i]]=true;
}
for(int i=0;i<s1.length();i++){
if(!mark[s1[i]]) cout<<s1[i];
}
cout<<endl;
return 0;
}