1078 Hashing (25 point(s))
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then Ndistinct positive integers are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.
Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -
翻译:Quadratic probing(with positive increments only) 正向平方探测法
参考链接:https://blog.youkuaiyun.com/qq_37142034/article/details/87903983
体会哈希思想(哈希表)的应用。
特别的坑:注意到输入最大为1e4,因此应当至少能够判断出大于1e4的最小素数。由于我这里用的是素数筛法,我最初习惯性地将数组大小开为1e4+7,由此可以使用素数筛法可以筛选到的最大素数范围是2~1e4+6,而恰巧比10000大的最小素数是1e4+7,导致case#3和case#4一直不能通过(15分)。
#include<iostream>
using namespace std;
const int N = 10013;
bool mark[N]={false};
int prime[N];
int ht[N];
int index = 0;
void init(){
for(int i=2;i<N;i++){
if(mark[i]) continue;
for(int j=i*i;j<N;j=j+i){
mark[j]=true;
}
}
for(int i=2;i<N;i++){
if(!mark[i]) prime[index++]=i;
}
}
int main(void){
init();
int M,N,size,key;
cin>>M>>N;
for(int i=0;i<index;i++){
if(prime[i]>=M){
size = prime[i];break;
}
}
for(int i=0;i<size;i++) ht[i]=-1;
for(int i=0;i<N;i++){
cin>>key;
if(i!=0) cout<<" ";
int pos = key%size;
if(ht[pos]==-1){//hash表该项为空
ht[pos]=key;
cout<<pos;
}
else{//发生冲突,线性平方探测
bool flag =false;
for(int i=1;i<=size-1;i++){
int npos = (key+i*i)%size;
if(ht[npos]==-1){
cout<<npos;
ht[npos]=key;
flag=true;
break;
}
}
if(!flag) cout<<"-";
}
}
return 0;
}