A Cubic number and A Cubic Number---ACM青岛Regional

A Cubic number and A Cubic Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4947    Accepted Submission(s): 1346


Problem Description
A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125 . Given an prime number p . Check that if p is a difference of two cubic numbers.
 

Input
The first of input contains an integer T (1T100) which is the total number of test cases.
For each test case, a line contains a prime number p (2p1012) .
 

Output
For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.
 

Sample Input
  
  
10 2 3 5 7 11 13 17 19 23 29
 

Sample Output
  
  
NO NO NO YES NO NO NO YES NO

NO

题目大意:输入素数判断它是否是任意两个立方数的差,如果是输出“YES” 否则“NO”

#include <stdio.h>
int main()
{
	int x,n;
	long long num,i;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%lld",&num);
			for(i = 2;i<=1000000;i++)
		{
			if(num - 1 == 3*i*i - 3*i)//根据立方差公式可化简得到此式
			{
				printf("YES\n");
				break;
			}
			else if(num -1 < 3*i*i - 3*i)
			{
				printf("NO\n");
				break;
			}
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值