1054 The Dominant Color(20 分)

博客围绕图像主颜色判断问题展开,给定分辨率为M×N的图像,要求找出严格主颜色(占比超一半)。输入包含图像分辨率及各像素颜色,输出为主颜色。解题时简单用数组会超内存,需用map映射。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1054 The Dominant Color(20 分)
Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2
​24
​​ ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:
For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24

解题思路:
简单使用数组的话会超内存,要用map映射。

#include<cstdio>
#include<map>
using namespace std;
int main(){
    int n,m,ans,temp;
    map<int,int>mp;
    scanf("%d%d",&m,&n);
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            scanf("%d",&temp);
            if(mp.find(temp)!=mp.end()  )   mp[temp]++;
            else mp[temp]=1;
            if(mp[temp]*2>n*m) ans=temp;
        }
    }
    printf("%d",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值