题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=2577
How to Type
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5003 Accepted Submission(s): 2248
Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3 Pirates HDUacm HDUACM
Sample Output
8 8 8HintThe string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
Author
Dellenge
这题有点类似15年的一题多校赛,该题的题解链接 http://blog.youkuaiyun.com/chenninggo/article/details/48210123
同样的道理,每一个字母输入完后都会2种状态,开着大写键和关着大写键,那么就用dp记录开着大写键的步数和关着大写键的步数。
有一个注意的地方,当开着大写键时,按下shift键和输入的字母,是可以输出小写字母的
代码如下
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int t, i;
int op[110], cl[110];
char cc[110];
int main()
{
// freopen("input.txt", "r", stdin);
scanf("%d", &t);
while (t--)
{
memset(op, 0, sizeof(op));
memset(cl, 0, sizeof(cl));
memset(cc, 0, sizeof(cc));
scanf("%s", cc + 1);
op[0] = 1; //在未输入的时候就已经按下了大写键,所以初始步数位1
cl[0] = 0;
for (i = 1; cc[i] != 0; i++)
{
if (cc[i] >= 'a' && cc[i] <= 'z')
{
cl[i] = min(op[i - 1] + 2, cl[i - 1] + 1);
op[i] = min(op[i - 1] + 2, cl[i - 1] + 2);
}
else if (cc[i] >= 'A' && cc[i] <= 'Z')
{
cl[i] = min(op[i - 1] + 2, cl[i - 1] + 2);
op[i] = min(op[i - 1] + 1, cl[i - 1] + 2);
}
}
printf("%d\n", min(cl[i - 1], op[i - 1] + 1)); //因为最后的状态是关着大写键的,所以op数组要+1,表示最后一个字母输入完后关闭大写键
}
return 0;
}