ACMer
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4132 Accepted Submission(s): 1891
Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
Output
For each test case, output the minumal number of students in HDU.
Sample Input
1 13.00 14.10
Sample Output
15
#include<cstdio>
#include<cmath>
int main()
{
int ncase;
double p,q;
scanf("%d",&ncase);
while(ncase--)
{
scanf("%lf %lf",&p,&q);
for(int i=1;;i++)
{
if(floor(i*p/100)<floor(i*q/100))
{
printf("%d\n",i);
break;
}
}
}
return 0;
}