Stars POJ - 2352

题目链接:点我


    Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

这里写图片描述

    For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

    You are to write a program that will count the amounts of the stars of each level on a given map.

Input

    The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

    The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题意:

给你一群星星的坐标,要你求每个星星的左下共有多少颗星星.输出level由0 到n-1的星星的个数.

思路:

树状数组,由于题目中所有的星星是按照y的升序来输入的,所以我们只需要查询坐标小于等于它的星星共有多少颗即可.

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

const int maxn = 32005;
int a[maxn];
int level[maxn];
int n;

void add(int x){
    while(x < maxn){
        a[x] ++;
        x += x&-x;
    }
}

int sum(int x){
    int ans = 0;
    while(x > 0){
        ans += a[x];
        x -= x&-x;
    }
    return ans;
}

int main(){
    while(scanf("%d", &n) != EOF){
        memset(a, 0, sizeof(a));
        memset(level, 0, sizeof(level));
       for(int i = 0;i < n; ++i){
        int x, y;
        scanf("%d %d", &x, &y);
        ++ x;
        level[sum(x)] ++;
        add(x);
       }
       for(int i = 0; i < n; ++ i)
        printf("%d\n",level[i]);
    }
    return 0;
}
### POJ2352 Stars 夜空星辰 解题思路 对于给定的一系列星星,按照Y坐标升序排列(如果Y相同,则按X升序),目标是计算每一颗星的等级。一颗星的等级定义为其左下方(含正下和正左)区域内的星星数量[^2]。 为了高效解决此问题,可以采用树状数组(Binary Indexed Tree, BIT),它能够支持快速更新和查询前缀和操作,在本题目中用于维护并查询某个范围内已有的星星数目。具体来说: - 初始化一个长度为最大可能横坐标的数组`bit[]`来作为树状数组结构。 - 遍历每一个星星的位置(x,y),通过调用`update()`函数增加该位置对应的计数值;在此之前先利用`query()`获取当前x之前所有位置上的累计值即为这颗星的level级别。 这种方法的时间复杂度主要取决于遍历过程中的单次增删查改操作时间开销O(logn),因此整体性能表现良好适合处理较大规模的数据集。 ```cpp #include <iostream> using namespace std; const int MAX_X = 32000; int bit[MAX_X + 1], n, cnt[15005]; // 获取最低位1所代表的值 inline int lowbit(int x){ return x & (-x); } void update(int pos, int val){ while(pos <= MAX_X){ bit[pos] += val; pos += lowbit(pos); } } int query(int pos){ int sum = 0; while(pos > 0){ sum += bit[pos]; pos -= lowbit(pos); } return sum; } struct Star{ int x, y; }star[15005]; bool cmp(Star a, Star b){ if(a.y != b.y) return a.y < b.y; else return a.x < b.x; } int main(){ cin >> n; for(int i = 0;i < n;++i) scanf("%d%d", &star[i].x, &star[i].y); sort(star, star+n, cmp); memset(bit, 0, sizeof(bit)); for(int i = 0; i<n ; ++i){ // 查询小于等于当前位置的最大索引处有多少个元素 cnt[query(++star[i].x)]++; // 更新BIT update(star[i].x , 1); } for(int i = 0; i<=n ;++i ) cout<<cnt[i]<<endl; return 0; } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值