浅谈MIME

Java开发的B/S程序生成并向客户端发送excel文件:浅谈MIME Java开发的B/S程序生成并向客户端发送excel文件:浅谈MIME 1、定义 MIME(Multipurpose Internet Mail Extensions)多用途互联网邮件扩展类型。是设定某种扩展名的文件用一种应用程序来打开的方式类型,当该扩展名文件被访问的时候,浏览器会自动使用指定应用程序来打开。多用于指定一些客户端自定义的文件名,以及一些媒体文件打开方式。 它是一个互联网标准,扩... 阅读详情
多用途互联网邮件扩展(MIME,Multipurpose Internet Mail Extensions)是一个互联网标准,它扩展了电子邮件标准,使其能够支持非ASCII字符、二进制格式附件等多种格式的邮件消息。这个标准被定义在;RFC 2045,; RFC 2046,; RFC 2047,; RFC 2048,; RFC 2049等RFC中。 由RFC 822转变而来的RFC 2822,规定电子邮件标准并不允许在邮件消息中使用7位ASCII字符集以外的字符。正因如此,一些非英语字符消息和二进制文件,图像,声音等非文字消息都不能在电子邮件中传输。MIME规定了用于表示各种各样的数据类型的符号化方法。 此外,在万维网中使用的HTTP协议中也使用了MIME的框架。 

MIME headers 
MIME是通过标准化电子邮件报文的头部的附加领域(fields)而实现的;这些头部的附加领域,描述新的报文类型的内容和组织形式。 

MIME版本 
MIME版本(MIME-Version),这个头部领域在邮件消息的报文用一个版本号码来指明消息遵从的MIME规范的版本。目前版本是1.0。 

MIME-Version: 1.0 

内容类型 
内容类型(Content-Type),这个头部领域用于指定消息的类型。一般以下面的形式出现。 

Content-Type: [type]/[subtype]; parameter 
type有下面的形式。 
Text:用于标准化地表示的文本信息,文本消息可以是多种字符集和或者多种格式的; 
Multipart:用于连接消息体的多个部分构成一个消息,这些部分可以是不同类型的数据; 
Application:用于传输应用程序数据或者二进制数据; 
Message:用于包装一个E-mail消息; 
Image:用于传输静态图片数据; 
Audio:用于传输音频或者音声数据; 
Video:用于传输动态影像数据,可以是与音频编辑在一起的视频数据格式。 
subtype用于指定type的详细形式。content-type/subtype配对的集合和与此相关的参数,将随着时间而增长。为了确保这些值在一个有序而且公开的状态下开发,MIME使用Internet Assigned Numbers Authority (IANA)作为中心的注册机制来管理这些值。常用的subtype值如下所示: 
text/plain(纯文本) 
text/html(HTML文档) 
application/xhtml+xml(XHTML文档) 
image/gif(GIF图像) 
image/jpeg(JPEG图像) 
image/png(PNG图像) 
video/mpeg(MPEG动画) 
application/octet-stream(任意的二进制数据) 
application/pdf(PDF文档) 
application/msword(Microsoft Word文件) 
message/rfc822(RFC 822形式) 
multipart/alternative(HTML邮件的HTML形式和纯文本形式,相同内容使用不同形式表示) 
application/x-www-form-urlencoded(使用HTTP的POST方法提交的表单) 
multipart/form-data(同上,但主要用于表单提交时伴随文件上传的场合) 
此外,尚未被接受为正式数据类型的subtype,可以使用x-开始的独立名称(例如application/x-gzip)。vnd-开始的固有名称也可以使用(例:application/vnd.ms-excel)。 

parameter可以用来指定附加的信息,更多情况下是用于指定text/plain和text/htm等的文字编码方式的charset参数。MINE根据type制定了默认的subtype,当客户端不能确定消息的subtype的情况下,消息被看作默认的subtype进行处理。Text默认是text/plain,Application默认是application/octet-stream而Multipart默认情况下被看作multipart/mixed。


MIME类型就是设定某种扩展名的文件用一种应用程序来打开的方式类型,当该扩展名文件被访问的时候,浏览器会自动使用指定应用程序来打开。多用于指定一些客户端自定义的文件名,以及一些媒体文件打开方式。

 

每个MIME类型由两部分组成,前面是数据的大类别,例如声音audio、图象image等,后面定义具体的种类。

 
MIME 参考手册 MIME 类型 MIME (Multipurpose Internet Mail Extensions) 是描述消息内容类型的因特网标准。 MIME 消息能包含文本、图像、音频、视频以及其他应用程序专用的数据。 官方的 MIME 信息是由 Internet Engineering Task Force (IETF) 在下面的文档中提供的: RFC-822 Standard for ARPA Internet text messages RFC-2045 MIME Part 1: Format of Internet Message Bodies RFC-2046 MIME Part 2: Media Types RFC-2047 MIME Part 3: Header Extensions for Non-ASCII Text RFC-2048 MIME Part 4: Registration Procedures RFC-2049 MIME Part 5: Conformance Criteria and Examples 不同的应用程序支持不同的 MIME 类型。 下面的参考手册是由 Microsoft Internet Information Server version 5 所支持的 MIME 类型列表。 立即下载

相关推荐

机械臂 关节电机选型计算

电机 机械臂

hisen92的专栏 8983

HTTP基础知识

HTTP基础知识 1.基本内容 HTTP协议是Hyper Text Transfer Protocol(超文本传输协议)的缩写,是用于从万维网(WWW:World Wide Web )服务器传输超文本到本地浏览器的传送协议。HTTP是一个基于TCP/IP通信协议来传递数据(HTML 文件, 图片文件, 查询结果等)。 超文本传输协议(HTTP,Hyper Text Transfer Protocol)是一个简单的请求—响应协议,它通常运行在TCP之上。它指定了客户端可能发送给服务器给什么的消息以及得到什么样

Chenhui的博客 2916

基于stm32的数控恒压恒流电源设计方案

基于stm32的数控恒压恒流电源设计方案 基于stm32的数控恒压恒流电源设计方案 不包实物,可自己动手制作,可代做 本设计采用220V市电输入工频变压器,将220V交流电压降为24V交流电压,经过全桥整流加电容滤波,输出约32V直流电压.可调输出电压方案采用线性稳压调整器方案,即运放处于比较调整状态,运放输出驱动P型MOS管,电压输出端由电阻分压反馈至运放同相输入端,运放反相输入端由STM32单片机控制TLC5615数模转换器输入模拟电压,根据运放构成比较器原理,运放的同相端和反相端始终趋向于电压相等的特

m0_72265581的博客 7221

电子邮件(SMTP、MIME、POP3、IMAP)

电子邮件是一种异步通信方式,通信时不需要双方在场。电子邮件把邮件发送到收件人使用的服务器,并放入收件人的收件箱种,收件人可以随时上网到自己使用的邮件服务器进行阅读。

努力学习UE5ing。。。为了自己梦中的游戏而努力中 6580

带标签的PHM2009齿轮箱数据集

PHM2009附加数据集—带标签的齿轮箱数据集,可用于测试算法

qq_39379705的博客 4873

用Python实现图片风格迁移,让你的图片更加的高逼格!

先来看下效果: 上图是老王在甘南合作的米拉日巴佛阁外面拍下的一张照片,采用风格迁移技术后的效果为: 一些其它效果图: 下面进入正题。 近年来,由深度学习所引领的人工智能(AI)技术浪潮,开始越来越广泛地应用到生活各个领域。这其中,人工智能与艺术的交叉碰撞,在相关技术领域和艺术领域引起了高度关注。就在上个月,由电脑生成的艺术品在佳士得(Christie’s)的拍卖价竟高达43.25万美元,...

Python追梦 6181

HTTP报文中的MIME type

MIME typeMIME type的缩写为(Multipurpose Internet Mail Extensions)代表互联网媒体类型(Internet mediatype),MIME使用一个简单的字符串组成,最初是为了标识邮件Email附件的类型,在html文件中可以使用content-type属性表示,描述了文件类型的互联网标准。是一种用于在异构系统、网络之间传递信息时时声明其格式的方法。MIME类型能包含视频、图像、文本、音频、应用程序等数据。一般的,在文件系统中,我们会使用扩展名来表示。

独舞风 733

UNet改进(47):Deformable Convolution在UNet中的集成与应用

本文提出了一种可变形U-Net(DeformableUNet)结构,通过在U-Net的双卷积模块中集成可变形卷积(DeformConv2d)来提升模型对物体形变和复杂结构的建模能力。传统卷积受限于固定感受野,而可变形卷积通过动态调整采样位置,能更好地适应不规则形状。实现中,在DoubleConv模块的第二个卷积层替换为可变形卷积,同时保持第一层为标准卷积以确保稳定性。实验表明,该方法在保持参数量基本不变的情况下,显著提升了分割精度(mIoU从0.712提升到0.743)。

2501_91516851的博客 201

浅谈MIME之文件下载

浅谈MIME之文件下载 要实现文件下载,我们只需要设置两个特殊的相应头。 它们是什么头?如果文件名带中文,该如何解决? 两个特殊的相应头: Content-Type: application/octet-stream 它定义了数据的类型,以便数据能被适当的处理。有效的类型有:text,image,audio,video,applications,multipart和message...

lingtouyang的博客 2451

【灰度共生矩阵(GLCM)原理及代码实现】

文章主旨详细介绍灰度共生矩阵(Gray-Level Co-occurrence Matrix, GLCM)的生成原理、核心特征量及其在图像纹理分析中的应用,并提供了可运行的Python代码实现。该网页是一篇理论结合实践的优秀技术文章。它不仅清晰地解释了GLCM这一经典纹理分析工具背后的数学原理,还提供了完整、可复现的代码,非常适合计算机视觉或图像处理领域的学习者和开发者入门并实践灰度共生矩阵。读者可以通过运行代码来直观理解GLCM如何工作,并提取图像的纹理特征。

blotemj.blog.youkuaiyun.com 179

081、空间降噪(Spatial Denoise)实战:双边滤波、非局部均值与BM3D在ISP中的调优

调参时,别只看PSNR/SSIM。找几个典型场景(夜景、人像、文字、天空),在真实设备上肉眼对比。我见过PSNR涨了2dB但图像看起来更差的案例——因为PSNR不惩罚纹理丢失。空间降噪这块,理论说再多,不如动手调一次。下次遇到噪点问题,先别急着上BM3D,试试双边滤波的自适应参数,说不定有惊喜。

zzfmlxs的博客 45

浅谈MIME类型?

在回顾JavaScript的时候看到MIME类型,由于开始没怎么关注 charset属性,所以对这个类型也不怎么了解,查了资料过后在这里记录一下,顺便分享出来。 1.来自百度百科的混乱概念 当我在谷歌浏览器中搜索MIME类型关键字的时候,百度百科弹了出来,它对这个词的解释是这样的 MIME(Multipurpose Internet Mail Extensions)多用途互联网邮件扩展类型。是设...

hei_xiaomian的博客 464

29、集成电路测试技术解析

本文深入解析了集成电路测试技术,涵盖定制电路测试资源与策略、混合模拟/数字电路测试方法、数字测试模式生成难点与解决方案,以及可控性和可观测性的核心概念。同时详细讨论了固定故障、桥接故障和开路故障等主要故障模型及其检测方法。在测试技术的综合应用与优化方面,提出了合理配置测试资源、优化测试模式和设计测试流程的策略。最后展望了测试技术的发展趋势,包括集成化测试、自动化测试和智能化测试。通过全面掌握这些测试技术,可以有效提高集成电路的质量和可靠性,推动集成电路产业的发展。

work3的博客 204

浅谈邮件的发送和接受(二)

创建邮件—— MIME协议 MIME协议是对RFC822文档的升级和补充,它描述了如何生成一封复杂邮件。通常我们把MIME协议描述的邮件称之为MIME邮件,MIME协议描述的数据称之为MIME消息。对于一封复杂邮件,如果包含了多个不同的数据,MIME协议规定了要使用分隔线对多段数据进行分隔,并使用Content-Type头字段对数据的类型、以及多个数据之间的关系进行描述。(查看outl

fengruifang的专栏 1141

C# WinForm 基于DirectShow.dll编写的程序,可边预览边保存视频,音频和图片

基于微软的DirectShow.dll的二次开发1.自动识别连接的摄像头跟麦克风且可以对其进行选择(默认选中第一个)2.可录制wmv和avi两种格式的视频并且都带有音频,avi可以录制的分辨率和帧数进行选择,wmv默认进行了淸晰度优化如不喜欢可去除代码中有相关提示3.可在预览点开之后进行拍照,也可边录制视频边拍照4.添加了视频和音频的压缩功能(酌情使用)这次二次开发发现C#对DirectShow的相关信息太少,这次做完也不敢藏私共享出来,还望大家指正

假人有限元模型

假人模型,车辆碰撞假人有限元模型,适合做乘员安全的研究者利用

浅谈用delphi来编写蠕虫病毒

 前言: 可能大家想到病毒,第一反应就是可能是用asm来编写,或者是vbsript,而高级语言如delphi就好象不能编写一样,其实事实并不是这个样子的,只要我们花一些时间,照样可以写出简短而高效的病毒程序来,一点也不输那些用汇编写出来的程序哦。 一个病毒程序首先要短小,我们的目标是经过压缩后控制在30k以下。用过delphi的朋友都知道,如果在uses里面加入forms,classes.....

人类若不做超越能力的攀登,那么天空和神祗的存在又有何意义? 1529

visio安装包

Microsoft Office Visio 是一款专业的制图软件。利用经过更新的形状、协作工具和数据链接图表,创建专业级图表以简化复杂的信息。

浅谈HTTP协议

Http超文本传输协议 Http是应用层协议,是一个基于请求/响应模式的,无状态的协议。 Http使用的是可靠的基于连接的数据传输协议TCP协议。 HTTP1.1版本中,给出了一个“持续连接”的机制,并将其作为HTTP1.1中建立连接的缺省行为。通过这种连接,客户端可以连续发送多个请求,而不用等待每个响应的到来。   一、浏览器与服务器通信的过程:   二、资源 平时上网所看到

启航 754

WINCC7.3破解文件

WINCC7.3硬件够破解文件,有需要的下载!WINCC7.3硬件够破解文件,有需要的下载!

浅谈HTTP请求头content-type

请求消息和响应消息都可以包含实体信息,实体信息一般由实体头域和实体组成。实体头域包含关于实体的原信息,实体头包括Allow、Content- Base、Content-Encoding、Content-Language、 Content-Length、Content-Location、Content-MD5、Content-Range、Content-Type、 Etag、Expires、Las...

细雨纷飞~~~ 686

浅谈HTTP请求

HTTP通信机制是在一次 完整的HTTP 通信 过程 中 ,WEB浏览器 与  WEB  服务器 将完成 下列 七个步骤: 1. 建立TCP连接    在HTTP开始工作之前,web浏览器 首先 要通过 网络 与 web 服务器 建立连接 ,该连接 是通过 TCP 来完成的,TCP协议 与 IP协议 共同 构建 Internet,即著名的TCP/IP协议族,因此Internet

ZeroDegree°的博客 321

浅谈HTML5中的二进制大对象Blob

1、Blob是什么? 在计算机中,Blob常常是数据库中用来存储二进制文件的字段类型,MySQL中的Blob类型就只是个二进制数据容器。 在HTML5中,Blob是一种JavaScript的对象类型,Blob对象除了存放二进制数据外还可以设置这个数据的MIME类型,这相当于对文件的存储。一个Blob对象是一个包含只读原始数据的类文件对象。 2、创建Blob对象 在新的方法中可以直接

筱葭的博客 6061

H5应用程序缓存浅谈及实际测试

应用程序缓存能做什么? 可以在脱离网络的条件下离线访问。 减少读取服务器文件,减轻服务器的访问压力。 优化网站打开速度。 如何启用应用缓存? 第一步:给服务器添加新的MIME:扩展名:.appcach...

qq_45670012的博客 252

浅谈文件上传漏洞

前言 一、文件上传漏洞的原理 二、 ## 1. 2. 总结 提示:这里对文章进行总结: 例如:以上就是今天要讲的内容,本文仅仅简单介绍了pandas的使用,而pandas提供了大量能使我们快速便捷地处理数据的函数和方法。 ...

qz362228的博客 1万+

浅谈Linux下file的应用实例

这个咋听着这么拗口,其实很简单,其实并不难,加上-f参数,是file-from类型的含义,到底是几个意思呢,也就是你想查看文件的类型信息的文件名在一个文件里面,从这个文件里面读取文件来的到信息,如下即可晓得。默认情况下,如果没有L参数,只能得到这个文件是软链接的信息,如果加上这个参数,就能看到源文件的文件信息,这个功能还是很赞的。加上-b参数,是brief的含义,将只显示文件辨识结果,不显示文件名称了,这个其实对于很多文件而言,不是很友好。也就是说可以识别文件类型的意思,也可用来辨别一些文件的编码格式。

Free雅轩的博客 122

java web中web.xml配置【精】_浅谈JavaWeb中的web.xml配置部署描述符文件

浅谈JavaWeb中的web.xml配置部署描述符文件发布于 2020-6-17|复制链接下面小妖就为大家带来一篇浅谈JavaWeb中的web.xml配置部署描述符文件。小妖觉得挺不错的,现在就分享给大家,也给大家做个参考。一起跟随小妖过来看看吧1、 定义头和根元素部署描述符文件就像所有XML文件一样,必须以一个XML头开始。这个头声明可以使用的XML版本并给出文件的字符编码。DOCYTPE声明必...

weixin_31002061的博客 241

浅谈------什么是HTTP协议

一、http协议 应用层协议 构建网站服务 在客户端和服务器之间传递数据 作用 在客户端,web服务器传送数据 Hyper Text Transfer Protocol 超文本传输协议 客户端访问web服务器是,传递代码,由浏览器解析代码进行展示 二、web服务 1、类型 静态网站 网页上所有的资源都是固定的 HTML语言,js、jquery *.html

ljh451321的博客 1652
上一篇: Java中的Set集合类
下一篇: Android学习笔记之AndroidManifest.xml文件解析
hxwhou
博客等级 码龄16年 100粉丝 64原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

个

红包个数最小为10个

元

红包金额最低5元

当前余额3.43元 前往充值 >
需支付:10.00元
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值